Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2008

    Unanswered: Sybase 5.5.05 database conversion to Sybase

    We currently are using Sybase for the database for our software. However, support for this old database version is now limited, so we are trying to convert to a newer version of Sybase. I used dbunload to convert the old database to Sybase version 10.1. The conversion
    went smoothly, and our application worked fine, until we tried deleting a record with a foreign key that was owned by another entity. We think that the
    foreign keys may not be passing correctly, in the converted version of
    the database, all of the keys are located under the system triggers, and
    those with referential integrity are not there. I don't know much about the newer version of Sybase, so it may in fact be converting properly. This is the syntax I
    used to convert the database: dbunload -c
    "uid=*****;pwd=*****;dbf=c:\database\database. db" -an c:\database\database1.db

    Did I forget to add any switches?

    It is also possible that our software itself is not compatible (im not the programmer) with the newer version, but we do not use any stored procedures and triggers, really the database is used only for storing data, almost all of the logic is done by the software itself.

  2. #2
    Join Date
    Jan 2008
    Ok, well we are pretty sure now that version 10 isnt the problem. We also tried converting to Sybase 6 and Sybase 8, and we get the exact same problems in our program. Even running the 5.5.05 database (not converting it) under the Sybase 6 server, the same problem occurs.

    Was there a change in Sybases ODBC functionality going between versions 5 and 6?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts