Hi, Im facing a problem and its getting me without any ideas, hopefully anyone could give me one over there out.

We have a db2 8.2 Enterprise Edition, on AIX 5.3 Platform, this is our production database. We had to do a full restore over this database for a problem with a tablespace. The problem cames after 5 days after full restore.

The problem is the following, we are having erratic, fluctuating size on our backups, and this is happening since 2 weeks ago, 5 days after full restore, as you can the following list of ls -l on 3 backups shows the error.

-rw-r----- 1 db2inst1 db2grp1 36435939328 Jan 26 01:10 PICASO.0.db2inst1.NODE0000.CATN0000.20080126004501 .001
Sun Jan 27 00:10:00 EST 2008

-rw-r----- 1 db2inst1 db2grp1 29490171904 Jan 27 01:05 PICASO.0.db2inst1.NODE0000.CATN0000.20080127004501 .001
Mon Jan 28 00:10:00 EST 2008

total 76685448
-rw-r----- 1 db2inst1 db2grp1 39262900224 Jan 28 01:12 PICASO.0.db2inst1.NODE0000.CATN0000.20080128004501 .001

The first day was : 33.9 G
Second day was:27.5G
Third day was:36.56G

The database according to control center in storage management is having a size of 27440MB, snapshot taken at:2008-01-26.

As you can see we have been having the up and down of the size of backups without reason, the database cant grow 9G in just one day, the max size of growning of this backup in one is 1G, and besides we don't delete huge information on this db, actually this database is transaccional is not a datawarehouse.

In the other hand, the backups dates according to db2 are different to OS. For example, according to DB2 the backup process finished at 01:40 am, but OS date says the backup finished at 01:08 am. Im pasting the db2 list history backup, so you can see other error with date:

Start Time: 20080126004501
End Time: 20080126014126
Status: A

Start Time: 20080127004501
End Time: 20080127013707
Status: A

Start Time: 20080128004501
End Time: 20080128014341
Status: A

DB2 does not show errors neither db2diag.log, neither db2ckbkp. Actually we have a shell to automatize backup online, the shell always runs a db2ckbkp, and always shows :
the Image Verification Complete - successful.

We ran a db2dart over our database and didnt say anything error, we restarted the database, and also operating system.

Now im going to tell you the operations what we did over database before this problem presented.

Four days before we cleaned 2 huges tables, one with 48G of size, and the other with 16G of size.

We started to run a shell to move the archive logs to a backup server 3 days before started problem, using rsync --remove-sent-files, and this shell ran every 10 mins, but we stoped this shell to see if this could be the reason for the problem.

These have been all changes or activities over this database.

Hopefully anyone over there out can give me a idea, why this is happing and what we could do.

Thanks in advance,