Hi,
I have an issue with the output of "onlog -l".

I created a simple table:
create table t1 (a char(10), b char(10), c char(10));
insert into t1 values ('aaaaaaaaaa','bbbbbbbbbb','cccccccccc');

and I updated column c:

update t1 set c='gggggggggg';

Now I am looking at the output of "onlog -l" to see the UPDATE representative and this is what I get:


addr len type xid id link

d5044 84 HUPDAT 5 0 d5018 20003d 101 0 30 30 1

54000000 00004900 10000000 00002074 T.....I. ...... t
05000000 18500d00 e98c0500 3d002000 .....P.. ....=. .
3d002000 01010000 00000000 1e001e00 =. ..... ........
01000000 00000000 00000000 0014000a ........ ........
63636363 63636363 63636767 67676767 cccccccc ccgggggg
67676767 gggg


As you can see, the binary data contains only the before/after image of the column that was updated (ccccccccccgggggggggg).

My question is whether there is a way to force the database to write all the columns values to the logical logs the same way it does in case I do an insert??
In other words, Is there a way to turn off the audit compression?
I know how to do it in other datatabases (In Oracle it's ALTER TABLE ADD SUPPLEMENTAL LOG, In SQL/MP it's ALTER TABLE NO AUDITCOMPRESS). What's the equivalent in informix??

Thanks,
Sami.