Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2006
    Location
    San Francisco, CA
    Posts
    136

    Unanswered: MOSS Collation Question

    Hey guys,
    I am working on the database side of an upgrade for our Sharepoint site to MOSS 2007. The current environment is SQL Server 2005 (SP2) clustered (8 dual core CPUs, 32GB RAM) with about 0.75 TB of data (about 10 different dbs). I noticed that the collation on the sharepoint databases are not the same as the system databases and other user databases.

    The collation setting for our current Sharepoint is:
    Latin1_General_CI_AS_KS_WS

    The collation setting for MOSS is:
    Latin1_General_CI_AS_KS_WS

    The collation setting for our system databases is:
    SQL_Latin1_General_CP1_CI_AS

    The collation setting for the server is:
    SQL_Latin1_General_CP1_CI_AS

    I am aware of the following issues with having different collation settings between user databases and system databases.
    http://sqlblogcasts.com/blogs/tonyro...07/12/883.aspx

    http://support.microsoft.com/kb/843578

    Currently nothing is broken, everything is working fine; So my question is:
    What does best practices suggest I do in this situation?
    Do I leave everything as is? Do I change the server collation and system databases?

    Any suggestions and feedback will help.
    Thanks,
    Reghardt

  2. #2
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    We have left everything as it is, and we have had no problems. In SQL 2005, the collation in temp tables is governed by the default collation of the user database context the query is run from, so those errors now go away in SQL 2005.

  3. #3
    Join Date
    Aug 2006
    Location
    San Francisco, CA
    Posts
    136
    That is great news, thanks for the info.

  4. #4
    Join Date
    Aug 2009
    Posts
    1
    Hi Reghardt,

    Are you cintinuing with collation settings "SQL_Latin1_General_CP1_CI_AI " or did you change to "Latin1_General_CI_AS_KS_WS " in order to match collations settings of Share point databases.

    We also have collations as below:

    System databases collations: SQL_Latin1_General_CP1_CI_AI
    Share point databases collations:Latin1_General_CI_AS_KS_WS

    Our share point application is in production from past 6 months But so far we did not get any issues.

    Please confirm

    Regards,
    Mamata
    Mamata

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •