Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2007
    Posts
    17

    Unanswered: Lost PHP access to SQL server...

    Hi All

    I am posting this in the hopes someone has come across the same issue and found a solution. The other day i uninstalled Microsoft ISA server 2000 from my SQL / Web server. Since then i have not been able to connect to the sql server via php. I changed the php config file and pointed it at another sql server i have up for development purposes that has a recent copy of the same db and everything works properly.

    The errors php is throwing at me show that it is not even able to find the server at all. I have changed it several times from both the netBios name as well as the actual ip and nothing seems to work.

    I should also note that other than the php access issue sql seems to be working perfectly for all other users in the office that are accessing it through the accounting system.

    System:
    Ms SQL 2000
    Windows Server 2003
    php 5 on IIS 6

    Any ideas?

    Thanks
    pT

  2. #2
    Join Date
    Nov 2004
    Location
    on the wrong server
    Posts
    8,835
    Provided Answers: 6
    has the port the sql server is using changed? check ther server network utility. if it is something other than 1433, do you have that specified in your connection string.

    have you checked whether the sql server and the client are using the same network protocols?

    are we sure the sql server account that php was using is still valid?

    can you ping the sql server from the machine that is running your php?
    “If one brings so much courage to this world the world has to kill them or break them, so of course it kills them. The world breaks every one and afterward many are strong at the broken places. But those that will not break it kills. It kills the very good and the very gentle and the very brave impartially. If you are none of these you can be sure it will kill you too but there will be no special hurry.” Earnest Hemingway, A Farewell To Arms.

  3. #3
    Join Date
    Jan 2007
    Posts
    17
    Hi Thrasymachus

    dbl checked the port assignment in network util it is set to port 1433 and hide server box is unchecked (dont know if that would matter or not)

    SQL and IIS are on the same server (bad practice i know but a temporary solution until i throw another server in there) so i imagine the network protocol is okay, but i am unsure how to go about checking this.

    The account that php was using is still valid and i have also tried with my own credentials with the same result.

    the server is responding to pings.

    The only thing that was changed at all was the removal of isa server 2000, which had its little fingers into everything it seems as server performance increased dramatically after its removal.

    Thanks for your suggestions. I'll keep plugging away.

    pT

  4. #4
    Join Date
    Jan 2007
    Posts
    17
    Fixed the problem and felt i should post the solution here so to perhaps help another that comes across the same issue.

    Turns out the problem was coincidently unrelated to the ISA uninstall, and the the sql calls were working sporadically after many a refresh. Something In the W2k3 sp2 install had created this problem but i am unsure as to exactly what.

    Solution: What i did to fix it was to enter the network configuration for the given SQL instance and disable tcp/ip restart SQL server, go back into network config and re-enable tcp/ip. Restart SQL again. After that all was well again.

    Hope this helps prevent someone else pulling their hair out unnecessarily.

    pT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •