Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2008
    Posts
    1

    Unanswered: Bulk Load in Oracle, problem with . (period) instead of a , (comma)

    Hi,

    I'm trying to make a bulk load (through sqlldr) in oracle, but the problem is that the file has a field with decimal numbers separated by a period, i changed a few registers to a comma and it worked, but there are so many registers to do that manually.

    I found the ALTER SESSION SET NLS_NUMERIC_CHARACTERS = ',.' command, but the problem is that this is called in oracle, not sql*loader (sqlldr is only for DDL), thus making it in different session.

    Any recommendation for this problem?

    Kindest Regards

    Hugo

  2. #2
    Join Date
    Nov 2003
    Posts
    2,933
    Provided Answers: 12
    You can use the to_number function:

    numeric_field "TO_NUMBER(:numeric_field,'09,99')"

    check out the manual for details on the to_number formats. I haven't tried the above syntax, but you can test it in SQL*Plus using e.g.
    Code:
    SELECT to_number('3,14', '9,99')
    FROM DUAL;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •