Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2008
    Posts
    8

    Unanswered: I can't type new data into new record.Help pls!!!

    Hi all,
    I have a form named STUDENT_CV.On this form, I created button" NEW" to add new student.But I can't add new data although i have a new record when click NEW button.What's the matter I've met?And how to solve it?

  2. #2
    Join Date
    Jun 2007
    Location
    Maitland NSW,Australia
    Posts
    388
    Please provide more details, do you receive an error message etc.?

  3. #3
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    Id check the form is enabled for data entry
    I'd check the backing query is a table query, ie it can be updated

  4. #4
    Join Date
    Mar 2008
    Posts
    19

    keys

    If you have any key field(s) that are not using autonumber, make sure they are on the page. The other fields won't be enabled until the key is entered. Recommend using autonumber for your keys though. It's best not to let the user type in a key.

  5. #5
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    Hmm I know what you're saying Nina, but that just doesn't cut it as an excuse to use an autonumber

    What code is running behind your button?
    Are you using bound or unbound forms?

    For bound forms you can do something like (note this is completely from memory)
    Code:
    DoCmd.GoToRecord acNewRecord
    Or bound forms you have to "submit" the data using an INSERT query.
    George
    Home | Blog

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •