Hello all,

While using IBM Data studio to build and debug a stored procedure, I am getting the following error and cannot continue with this task:

The error that i am getting is shown below:

eclipse.buildId=unknown
java.fullversion=J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32 j9vmwi3223ifx-20070323 (JIT enabled)
J9VM - 20070322_12058_lHdSMR
JIT - 20070109_1805ifx3_r8
GC - WASIFIX_2007
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product com.ibm.viper2.product.ide
Command-line arguments: -os win32 -ws win32 -arch x86 -product com.ibm.viper2.product.ide

Error
Fri Mar 07 05:57:53 EST 2008
Routine "*PILEMODE" (specific name "PSMD_SET_COMPMODE") is implemented with code in library or path "...nfenced/db2psmdr", function
"sdbg_CompileForDebug" which cannot be accessed. Reason code: "4". SQLCODE=-444, SQLSTATE=42724, DRIVER=3.50.152

com.ibm.db2.jcc.b.nm: Routine "*PILEMODE" (specific name "PSMD_SET_COMPMODE") is implemented with code in library or path "...nfenced/db2psmdr", function "sdbg_CompileForDebug" which cannot be accessed. Reason

code: "4".. SQLCODE=-444, SQLSTATE=42724, DRIVER=3.50.152
at com.ibm.db2.jcc.b.wc.a(Unknown Source)
at com.ibm.db2.jcc.b.wc.a(Unknown Source)
at com.ibm.db2.jcc.b.wc.a(Unknown Source)
at com.ibm.db2.jcc.b.tk.b(Unknown Source)
at com.ibm.db2.jcc.b.tk.c(Unknown Source)
at com.ibm.db2.jcc.t4.db.k(Unknown Source)
at com.ibm.db2.jcc.t4.db.e(Unknown Source)
at com.ibm.db2.jcc.t4.t.e(Unknown Source)
at com.ibm.db2.jcc.t4.sb.j(Unknown Source)
at com.ibm.db2.jcc.b.tk.Q(Unknown Source)
at com.ibm.db2.jcc.b.uk.e(Unknown Source)
at com.ibm.db2.jcc.b.vk.Bb(Unknown Source)
at com.ibm.db2.jcc.b.vk.execute(Unknown Source)
at org.eclipse.wst.rdb.internal.core.connection.Calla bleStatementAdapter.execute(Unknown Source)
at com.ibm.datatools.routines.dbservices.luw.sql.sp.S qlSPUNOBuilder.setCompileMode(Unknown Source)
at com.ibm.datatools.routines.dbservices.luw.sql.sp.S qlSPUNOBuilder.resetCompileMode(Unknown Source)
at com.ibm.datatools.routines.dbservices.luw.sql.sp.S qlSPUNOBuilder.run(Unknown Source)
at com.ibm.datatools.routines.dbservices.makers.Basic Builder.buildIt(Unknown Source)
at com.ibm.datatools.routines.dbservices.luw.Services ForLUWSQLSP.build(Unknown Source)
at com.ibm.datatools.db2.routines.deploy.DeployStates .deployUsingBuild(Unknown Source)
at com.ibm.datatools.db2.routines.deploy.DeployStates .deployRoutine(Unknown Source)
at com.ibm.datatools.db2.routines.deploy.DeployStates .deployRoutineList(Unknown Source)
at com.ibm.datatools.db2.routines.deploy.ui.wizard.De ployThread.run(Unknown Source)

This is my first time of using Data Studio and have no idea what I could be ding wrong. My research and the error message seems to suggest that "com.ibm.db2.jcc.b.nm: Routine "*PILEMODE" (specific name "PSMD_SET_COMPMODE" cannot be accessed. Reason code: "4".

Anyone with Data Studio experience know of this problem and have a recommendation or solution?

I will be highly appreciative of any assistance in resolving this problem.

Thank you all.