Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2003

    Unanswered: How to stop/force hanged on-line backup process?

    on DB2 v8.1 fp11 on "Linux System z" the on-line backup has frozen. It looks like the disk where database tablespace was on was full.

    I have cleaned out disk to make free disk space.

    I have checked the tablespace status and it is in backup in progress status:
    db2 list tablespaces show detail
     Tablespace ID                        = 2
     Name                                 = USERSPACE1
     Type                                 = System managed space
     Contents                             = Any data
     State                                = 0x0800
       Detailed explanation:
         Backup in progress
    I have monitored utilities to see the on-line backup progress and it is just frozen on 86%.
    db2 list utilities show detail
    ID                               = 7
    Type                             = BACKUP
    Database Name                    = ISQ
    Partition Number                 = 0
    Description                      = online db
    Start Time                       = 18.03.2008 06:45:12.525075
       Priority                      = Unthrottled
    Progress Monitoring:
       Estimated Percentage Complete = 86
          Total Work                 = 4754586791 bytes
          Completed Work             = 4106422415 bytes
          Start Time                 = 18.03.2008 06:45:12.536922
    1. how to make database to continue writing the on-line backup?
    2. or how to stop/force on-line backup?

    Last edited by grofaty; 03-18-08 at 04:39.

  2. #2
    Join Date
    Jan 2003
    I have solved the problem. Quite interesting: db2 event monitoring was off but was created few week ago with autostart option. Four days ago syadmin rebooted Linux and DB2 autostarted, so event monitoring has turned on because of autostart option. Event monitoring has fulled disk space at the time on-line backup was working and on-line backup has frozen. When event monitoring was stopped db2 on-line backup process finished. It just looks like event monitoring and on-line backup was in some kind lock mode.

    We tried to make an on-line backup manually and now it works fine. It just looks a chain reaction was triggered.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts