Results 1 to 9 of 9
  1. #1
    Join Date
    Sep 2003
    Location
    Switzerland
    Posts
    443

    Unanswered: Perl / Sybase 15 / libtli.so

    Anyone know what happened to libtli.so. In the 12.x versions, it was called as libtli.so.Version and now thats not even there in OCS_15-0

    Looks like it may have been changed to libsybtcl.so

    I can do a soft link to it, but any other things which I need to look for.

  2. #2
    Join Date
    May 2005
    Location
    South Africa
    Posts
    1,365
    Provided Answers: 1
    I recall this thread about sqsh (for libct, libcs, libblk)
    http://www.dbforums.com/showthread.p...6149&p=6315307

  3. #3
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    Quote Originally Posted by trvishi
    Anyone know what happened to libtli.so. In the 12.x versions, it was called as libtli.so.Version and now thats not even there in OCS_15-0

    Looks like it may have been changed to libsybtcl.so

    I can do a soft link to it, but any other things which I need to look for.
    It is now called libsybtli.so.15.x.y.z

    You do NOT need to link to it - this library gets loaded at run-time by OpenClient.

    Michael

  4. #4
    Join Date
    May 2005
    Location
    South Africa
    Posts
    1,365
    Provided Answers: 1
    There is a script to create links see

    # ls -l OCS-15_0/scripts
    total 6
    -rw-r--r-- 1 syb1502 sybase 673 Apr 21 2005 README
    -rwxr-xr-x 1 syb1502 sybase 1260 Apr 19 2006 lnsyblibs

  5. #5
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    I'll add that recent versions of DBD:: Sybase and sybperl will correctly pick up the OCS 15 libs...

    Michael

  6. #6
    Join Date
    Sep 2003
    Location
    Switzerland
    Posts
    443
    great. thanks Mike and pdreyer

  7. #7
    Join Date
    Sep 2003
    Location
    Switzerland
    Posts
    443
    Quote Originally Posted by mpeppler
    I'll add that recent versions of DBD:: Sybase and sybperl will correctly pick up the OCS 15 libs...

    Michael
    Hi Mike,

    How can the version be checked and is there any set of instructions to download and compile.

  8. #8
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    You can check the version of perl module with something like this
    Code:
    perl -MSybase::CTlib'(9999)'
    which will try to load version 9999 of the module, fail, and report the version that is installed.

    As for downloading/installing - the basic steps are (assuming Unix/linux)

    Code:
    download the package
    gunzip -c package.tar.gz | tar xvf -
    cd package
    perl Makefile.PL
    make
    make test
    make install
    The packages (DBD-Sybase-1.08.tar.gz and sybperl-2.18.tar.gz) both include READMEs that explain this is a little more detail.
    The main thing is to make sure that the SYBASE env. is properly positioned before running "perl Makefile.PL".

    Michael

  9. #9
    Join Date
    Sep 2003
    Location
    Switzerland
    Posts
    443
    Mike,

    I cant find libsybtli* in OCS_15.

    I guess the best option is to download the latest package and recompile.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •