Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2008
    Posts
    2

    Unanswered: Server Error when debugging stored procedure

    Hello,

    I have a stored proc which is already compiled and executed in DB2
    through toad, on debugging the proc thru TOAD
    i am getting the following error - which is server error as it shows under

    Unable to initialize debug session, server returned error code - 1879048118

    I am unable to find the solution to this and not able to debugg any procedure in the schema

    Please Help ,

    Thanks & Regards
    Aakansha!!!!!!!!!!!!!

  2. #2
    Join Date
    Jan 2007
    Location
    Jena, Germany
    Posts
    2,721
    This error does not look like a DB2 error. So could you provide more details on what you try to do, which platform and version of DB2 you are using and pretty much anything that could potentially be helpful to figure out what exactly you attempted?
    Knut Stolze
    IBM DB2 Analytics Accelerator
    IBM Germany Research & Development

  3. #3
    Join Date
    Mar 2008
    Posts
    2

    Brief Description

    Thank You Knut for your assistance.

    The DAtabase Details are as follows:
    Version -DB2 Viper
    DB2 Database [DB2/LINUXX8664]
    Server Version -9.1.2



    Brief Explanation:

    I have developed a DB2 SQL PL program which i have successfully deployed(Compiled & Executed) through TOAD (Toad For DB2 - v3.0).
    Since, i am unable to get the desired output, i tried debugging the procedure (through TOAD itself).

    When i start debugging (through Debug Option in TOAD) ,
    It throws a pop up- giving the following message

    Unable to initialize debug session, server returned error code - 1879048118

    I tried to stop all processes and also disconnected all simulatenous connection to the server. But on retrying the same i got the same pop up message.


    I have attached 2 snap shots:
    1) The way i debug
    2) The pop up error error message i get after debugging
    Attached Thumbnails Attached Thumbnails debugging.JPG   server_error.bmp  

  4. #4
    Join Date
    Jan 2007
    Location
    Jena, Germany
    Posts
    2,721
    Again, this is not a DB2 error message (at least the message code is missing). So here is what I think: you run into some problem in TOAD. Contact the TOAD developers and get them to investigate and fix this.

    Here, we can probably help you to figure out what's wrong with your procedure. But for that, we need the details on that...
    Knut Stolze
    IBM DB2 Analytics Accelerator
    IBM Germany Research & Development

  5. #5
    Join Date
    Jun 2007
    Posts
    12

    Red face Dba

    hey -- hit the same thing. can't get the Toad product to debug on one database but it works fine on another. did you ever get an answer????

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •