Results 1 to 11 of 11

Thread: frm-40010

  1. #1
    Join Date
    Oct 2007
    Posts
    60

    Unanswered: frm-40010

    hi all

    in one of my forms i am using a button to take me to another form buy using OPEN_FORM ('FORM_NAME');
    but it giving me frm-40010 error..

    so how i can fix this

    thanx

  2. #2
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    This is what Oracle says:
    FRM-40010: Cannot read form %s.

    Cause:**One of the following:
    1. You entered a nonexistent form name.
    2. You typed an incomplete path.
    3. You do not have the proper privileges to run the form.
    4. You do not have a compiled copy of the form.

    Action:**Retype the form name correctly, provide the proper path name, compile the form, or contact the DBA.

  3. #3
    Join Date
    Oct 2007
    Posts
    60
    2. You typed an incomplete path

    where to type the path

    thanx

  4. #4
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    I use MS Windows XP and Oracle Developer Suite 10g, so I'd put it into the FORMS90_PATH string in Windows registry (as I don't like hard coding paths into my forms).

    Or, you might set it in the DEFAULT.ENV file.

  5. #5
    Join Date
    Oct 2007
    Posts
    60
    i didnt get it at all...can u explain little bit more please

    thanx

  6. #6
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    If your operating system is MS WIndows (XP?), then open registry editor and navigate to HKEY_LOCAL_MACHINE/ORACLE/HOME0. Locate FORMS90_PATH string and modify its value - add a directory which contains your forms (separate it from the rest of the string with a semi-colon).

    DEFAULT.ENV is a file located in ORACLE_HOME\FORMS90\SERVER directory. Open it with any text editor and set FORMS90_PATH to point to a directory which contains your forms.

  7. #7
    Join Date
    Oct 2007
    Posts
    60
    ok thanx..i solved the broblem by adding the path andsave as .fmx..


    thanx to u all

  8. #8
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Quote Originally Posted by Tomatito
    thanx to u all
    But, it's only me, Foot (singular, as opposed to feet (plural)).

  9. #9
    Join Date
    Oct 2007
    Posts
    60
    hahahhahahahhaha sorry dear i didnt see that...ya it only u always replaying to mee...thanx alot to u only

    and thanx for the grammer leson as well

    thanx

  10. #10
    Join Date
    Oct 2007
    Posts
    60
    hi there all

    i soveled the problem ....if any one needs help in this just let me know

    thanx

  11. #11
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Someone will certainly run into the situation you were in.
    You came here asking for help.
    Now that you solved it, it would be nice if you post the solution NOW!, not waiting until someone says "Hey, how did you do that?". You might be on 3-months vacation. You might stop working with Oracle. You might stop visiting dBforums. You might ... whatever.

    So, post it now, share the knowledge. Don't keep it for yourself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •