Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2008
    Posts
    12

    Unanswered: SQL Server Not Using TCP/IP

    Hello All,
    I am running SQL Server 2000 on a Windows XP SP2 Pro machine. I have SQL Server-->Network Configuration, the Client Network Utility and Server Network Utility set to use the TCP/IP protocol. It is configured to use the default port of 1433. When I run a SQL Profile it notes that SQL Server is using LPC protocol and not TCP/IP. If I check the errorlog for SQL, it shows 'SQL server listening on Shared Memory'. I ran a NETSTAT and I do not see anything else using my port. In the Client Network Utility, I unchecked 'Used shared memory' but then I cannot even get to my SQL server databases as it says connection failed. I found an article on MS with a similar issue but the registry fix provided did not help.

    Has anyone ever encountered this or have any ideas?
    Thanks

  2. #2
    Join Date
    Nov 2004
    Location
    on the wrong server
    Posts
    8,835
    Provided Answers: 6
    what and where is your client? what protocols are set up in the client network utility on that machine.

    do you have an exception set up in the windows firewall for sql server on port 1433?
    “If one brings so much courage to this world the world has to kill them or break them, so of course it kills them. The world breaks every one and afterward many are strong at the broken places. But those that will not break it kills. It kills the very good and the very gentle and the very brave impartially. If you are none of these you can be sure it will kill you too but there will be no special hurry.” Earnest Hemingway, A Farewell To Arms.

  3. #3
    Join Date
    Mar 2008
    Posts
    12
    Hi,
    My client is on the same machine. In the Client Utility TCP/IP is the only protocol enabled. I have my firewall disabled but I did too add an exception for port 1433.
    Thanks

  4. #4
    Join Date
    Nov 2004
    Location
    on the wrong server
    Posts
    8,835
    Provided Answers: 6
    you would not need any of that. same machine = shared memory.

    Why did you do this "I unchecked 'Used shared memory' "? This is how it works on the same machine. You do not use network protocols if you are not connecting over a network.

    I do not understand what your issue is.
    “If one brings so much courage to this world the world has to kill them or break them, so of course it kills them. The world breaks every one and afterward many are strong at the broken places. But those that will not break it kills. It kills the very good and the very gentle and the very brave impartially. If you are none of these you can be sure it will kill you too but there will be no special hurry.” Earnest Hemingway, A Farewell To Arms.

  5. #5
    Join Date
    Mar 2008
    Posts
    12
    The problem is, I have a local application on my PC which requires TCP/IP to connect. I realized after, just connecting via my local PC shared memory is used, but when I use another application to connect, it should use TCP/IP (and it wouldnt causing an error). The SQL error log has no reference to the TCP/IP protocol. I found an MS article - http://support.microsoft.com/kb/308766 - and I ended up running the SQL Server SP4 upgrade which resolved the issue. Thank You

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •