Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2002
    Location
    Minneapolis, MN
    Posts
    253

    Unanswered: ConnGetProxyPassword

    I'm trying to set up a very simple publication/subscription scenario. I'm just publishing one table and several stored procedures. I'm getting the following error when trying to generate the initial snapshot:

    Code:
    Unable to start execution of step 2 (reason: Error authenticating proxy min\anthony, system error: ConnGetProxyPassword). The step failed.
    I've never seen this error before. In the snapshot and logreader agent settings I am using my domain account to run them both under. I've verified I entered the password correctly.

    Has anyone else seen this?



    Thanks!
    Anthony Robinson

    "If I'm curt with you, it's because time is a factor here. I think fast, I talk fast, and I need you guys to act fast if you want to get out of this. So, pretty please - with sugar on top..."

  2. #2
    Join Date
    Jun 2004
    Location
    Far away from heaven
    Posts
    194
    Hi.
    have you added this account under SQL-SERVER-AGENT --> Proxies--> MIN\ANTHONY and add it to Replication Snapshot/Queue Reader?
    Make sure your domain account has privilliges in MSDB database.
    Cheers!





    !Direction is More Important than Speed!

    http://talatnauman.blogspot.com/

  3. #3
    Join Date
    Feb 2002
    Location
    Minneapolis, MN
    Posts
    253
    The account in question is a sysadmin on the SQL Server..

    There was already a proxy under REPLICATION DISTRIBUTOR. I went and added that same proxy to REPLICATION QUEUE READER and REPLICATION SNAPSHOT.

    No joy...still getting the same error.
    Anthony Robinson

    "If I'm curt with you, it's because time is a factor here. I think fast, I talk fast, and I need you guys to act fast if you want to get out of this. So, pretty please - with sugar on top..."

  4. #4
    Join Date
    Jun 2004
    Location
    Far away from heaven
    Posts
    194
    Hi.
    Is your SQL running on Cluster?

    Try restarting SQL Agent Service and check if your windows account is trusted for delegation and can impersonate the proxy account.

    As a last option; chose the option to "Run under the SQL Server agent service account" for the snapshot agent. (should work)
    Cheers!





    !Direction is More Important than Speed!

    http://talatnauman.blogspot.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •