Results 1 to 12 of 12
  1. #1
    Join Date
    May 2008
    Posts
    10

    Unanswered: sybase 12.0 help

    hi,

    I've done some searches, and can't find anything ..

    With windows 2000 server support ending soon, I'm faced with 20 servers that need to be upgraded to windows 2003 server.

    after running a few tests, my ASE 12.0.0.2 databases won't start after one of my 2003 upgrade. I can't upgrade to sybase 12.5 because the vendor, and application won't support them.

    I have managed to get the databases up by manually starting the server in a dos window (running the xp, and sql servers)

    anyone know what needs to be done to make 12.0 databases run as a service on 2003 ?

    Thanks!!!!

  2. #2
    Join Date
    Apr 2005
    Posts
    10
    hi

    As far as i know ASE 12.0 it wont run in windows 2003 and ASE 12.5 you can install in windows 2003 but it wont run.

    Regards,
    dennis

  3. #3
    Join Date
    May 2008
    Posts
    10
    well I did manage to make it work.

    Using srvany.exe from the resource kit.
    I just edited the registry (hkey_local_machine\system\currentcontrolset\servi ces\sybsql_DRS)
    edit the image path to be c:\reskit\srvany
    create a new key under that key (Parameters)
    3 new strings (under the paramaters key)
    application=c:\sybase\ase-12_0.....
    appparameters=
    appdirectory=c:\sybase

    service starts and stops like a champ, runs just fine, maybe even a little better than it did with win 2000.

    I'd be happy to help anyone else get it running.

  4. #4
    Join Date
    Jan 2004
    Posts
    545
    Provided Answers: 4
    If you use ASE, you need to upgrade to a certain EBF. I'm using ASE12.5, and that version needs at least EBF11449 to run.
    I'm not crazy, I'm an aeroplane!

  5. #5
    Join Date
    May 2008
    Posts
    10
    I did upgrade to 12.0.0.8, which was ebf13229, but the services still wouldn't start.. which is why I used the srvany from the reskit

  6. #6
    Join Date
    Jun 2009
    Posts
    4
    application=c:\sybase\ase-12_0.....
    appparameters=
    appdirectory=c:\sybase

    Hi ecourt - hope you're still monitoring this!!

    We're in exactly the same boat and I've tried your solution with a little progress but just want to clarify one of the lines in the registry modification.

    under "application=c:\sybase\ase-12_0....." what are the "dots" referring to? Is that an 'equivelant' path? I've entered it without the dots as follows:

    application=c:\sybase\ase-12.0

    Just wondered if there was something else I needed to do add.

    The service now starts but immediately stops again stating it has nothing to do.

    Any advice would be welcomed!

    Thanks ecourt!

  7. #7
    Join Date
    May 2005
    Location
    South Africa
    Posts
    1,365
    Provided Answers: 1
    It probably refers to the dataserver executable?

  8. #8
    Join Date
    Jun 2009
    Location
    South Africa
    Posts
    33
    The normal entries for a Sybase configured service has the image path as :
    <Drive_and_Path>sqlsrvr.exe -sServerName -C
    e.g.
    c:\Sybase\ASE-15_0\bin\sqlsrvr.exe -sSYBASE -C

    The -C tells the executable to look at the parameters as defined in the HKEY_LOCAL_MACHINE\SOFTWARE\SYBASE\Server\<ServerN ame>\Parameters key of the registry for it's startup parameters.
    In this section there are Values named Arg0 to Argn of type REG_SZ which defines the normal parameters passed to the executable for startup.
    The default 5 parameters are :
    Arg0 = -d<fully qualified pathname to master.dat> e.g. -dC:\Sybase\data\SYBASE_master.dat
    Arg1 = -s<ServerName> e.g. -sSYBASE
    Arg2 = -e<fully qualified pathname to ErrorLog> e.g. -eC:\Sybase\ASE-15_0\install\SYBASE.log
    Arg3 = -i<Directory/Path where sql.ini resides> e.g. -iC:\Sybase\ini
    Arg4 = -M<Directory/Path where Shared Memory files are placed> e.g. C:\Sybase\ASE-15_0

    ASE requires minimum startup parameters like the servername and the location to the master device. If not specified it will default to "SYBASE". Keep this is mind if your server is named something else.

    If you use srvany, you need to specify the full path to the executable, the parameters, and the startup path.
    I would suggest that your parameters for the service includes at least the minimum parameters that a similar Sybase-created service has :
    application=C:\sybase\ASE-12_0\bin\sqlsrvr.exe
    appparameters=dC:\sybase\data\master.dat -sMYSERVER -eC:\sybase\ASE-12_0\install\MYSERVER.log -iC:\sybase\ini -MC:\sybase\ASE-12_0
    appdirectory=C:\sybase\ASE-12_0\install

    Don't forget to create a service for the backupserver as well ( You do plan on making backups, don't you ? ).
    The executable for the backup server is :
    application=<Same_Path_as_ASE>\bcksrvr.exe
    appparameters=-SMYSERVER_BS -eC:\sybase\ASE-12_0\install\MYSERVER_BS.log -IC:\sybase\ini\sql.ini -MC:\sybase\ASE-12_0\bin\sybmbuf.exe -Lus_english -Jcp850
    appdirectory=C:\sybase\ASE-12_0\install


    The parameters are slightly different to ASE's. Note that the -L and -J are for Language and Character set, with the defaults for a Windoze installation as above. The -M indicates where the sybmultbuf executable is located.
    The backup server is usually named the same as the ASE server, with "_BS" appended to the name.
    Ensure you have it listed in the sql.ini file, and also make sure that it is added to the ASE's server list :
    exec sp_addserver SYB_BACKUP, ASEnterprise, MYSERVER_BS
    go

    That should be it. Oh, do ensure that the Sybase user or user that starts the service does have EXPLICIT rights set to have full access to the path where the shared memory files are located. If not, ASE might refuse to start with an error indicating that it could not allocate a shared memory region, after you have allocated more than the default amount of memory to ASE.
    After setting the rights, you might need to reboot the machine so that the Kernel can inherit the "new" rights for the path.

    [sarcasm]
    This is just one of the privileges you have when running Windows - you get to reboot your machines quite frequently.
    [/sarcasm]

  9. #9
    Join Date
    Jun 2009
    Posts
    4
    Thanks a million Lerac! As soon as I get time from my other (non-windows, and hence slightly less of a headache) chores I'll give your suggestion a test.

    Thanks again!

  10. #10
    Join Date
    Jun 2009
    Posts
    4
    Hi all, Thanks again for the support on this, it's very much appreciated!

    After following all the advice I've managed to actually get the service to start, but then it immediately stops stating that this sometimes happens if a service has nothing to do, such as the performance logs and alerts service.

    Any ideas?!?!

  11. #11
    Join Date
    Mar 2009
    Location
    Sydney, Australia
    Posts
    258
    This is just one of the privileges you have when running Windows - you get to reboot your machines quite frequently.
    Unix servers are rebooted, windoze servers are bounced. "Like a, rubber ball, I come bouncing back to, yoo hoo hoo" Bobby Vee.

    Reg entries are the place you spend the most time, especially before and after installing an SP, where you go when you want no one to find you.
    What about writing a CMD script. I know it is a bit brute force, but it always got me past this sort of windozey stuff.
    Last edited by Derek Asirvadem; 09-03-09 at 11:28.
    Regards
    Derek Asirvadem (Formerly DerekA)
    Information Architect / Senior Sybase DBA
    Copyright 2009 Software Gems Pty Ltd

    I answer questions from the Original Poster only. If you have a genuine question, as the moderators have requested, start a new thread.

    http://www.softwaregems.com.au

  12. #12
    Join Date
    Jun 2009
    Posts
    4
    Hi all,

    First I want to say thank you to everyone that helped me with this. Patient and helpful, exactly what you should expect from a forum, sadly, not met on most other forums I've participated in!

    I've managed to resolve this and get Sybase running as a service.

    As with Win2000 I used "instsrv.exe" to get the servince installed.

    Then Under: "HKLM\SYSTEM\CurrentControlSet\Services\<MY_SYBASE _SERVERNAME>" I added the path to the "srvany.exe", ie, "C:\Program Files\Windows Resource Kit\Tools\srvany.exe"

    Then I added a new key called "Parameters" under this entry and then under the "Parameters" key I added a string value called "Application" In the "Application" entry I entered: "E:\sybase\ASE-12_0\bin\sqlsrvr.exe -dE:\sybdata\master.dat -sMY_SYBASE_SERVER -eE:\sybase\ASE-12_0\install\errorlog -iE:\sybase\ini -ME:\sybase\ASE-12_0"

    Service now starts a treat with no complaints!

    Once again, thanks for all your help on here!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •