Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2008
    Posts
    17

    Unanswered: refreshing the database

    hi everyone,
    i need to refresh the test database with the production database, i want to find out the best way of doing this while i maintain the users on the test database as the users are different on the two databases.
    thank you.

  2. #2
    Join Date
    Jun 2003
    Location
    West Palm Beach, FL
    Posts
    2,713

    Cool

    Export / Import
    The person who says it can't be done should not interrupt the person doing it. -- Chinese proverb

  3. #3
    Join Date
    Apr 2008
    Posts
    28
    Hi,

    What is your oracle version? because 10g offers Datapump that is even better than exp/imp... for instance: uses direct load data when importing, which imp doesn't... another example, you may export from one side, and over the network transmit the stream, and import Datapump on your development database..really nice!

  4. #4
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >10g offers Datapump
    Which has BUG that can corrupt UTF8 data.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  5. #5
    Join Date
    Apr 2008
    Posts
    28
    ...please could you provide the Metalink note?

    I've used datapump since 2005 and I haven't any issue.

  6. #6
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    from Note:144808.1


    For the moment, do NOT use Expdp/Impdp when going to UTF8 or a other multibyte
    characterset on ALL 10g versions including 10.2.0.3 and 11.1.0.6.
    It will provoke data corruption!
    This is caused by the impdp Bug 5874989.
    The "old" exp/imp work fine. This problem is fixed in the upcoming
    10.2.0.4 and 11.1.0.7 patchsets.
    For 10.2.0.2 and 10.2.0.3 you can ask a backport for Bug 5874989
    if you need to use expdp/impdp.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  7. #7
    Join Date
    Apr 2008
    Posts
    28
    Ok, it warns about going to UTF8 or multibyte charactersets...it's not clear if 'going' is 'use' , or 'moving to', because expdp/impd may be used to migrate data charactersets.

    Anyway, seems that caution must be taken until Oracle release proper patchsets

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •