Results 1 to 2 of 2

Thread: Hung up insert

  1. #1
    Join Date
    Sep 2006
    Posts
    26

    Unanswered: Hung up insert

    The first problem was one user couldn't run my application. He had Windows XP with Sybase ASE odbc driver, and was getting Reserved Error (-7748) -- based on info posted on internet, we did the registry workaround, and he no longer gets an error, but the query just hangs.

    This is the query:

    INSERT INTO advcash_trades_staging
    SELECT trim(str(acctnumb)) AS stracctnumb, *
    FROM dbo_pdp_cash_valuables
    WHERE effective_date=datevalue("05/13/2008") And (buyer_mnemonic='ADVCASH' Or seller_mnemonic='ADVCASH')
    ORDER BY trade_date DESC;


    dbo_pdp_cash_valuables is a link to a table that is in a Sybase database. advcash_trades_staging is a local table in Access. I can query the select part with no problem, and this successfully retrieves all 9500 rows, but the Insert does not complete on this user's PC. (it doesn't succeed in inserting even the first row.)

    The two other users who have working queries have Windows 2000 with Sybase System 11 ODBC driver. I have tried removing the string conversion function, but the insert never happens. I have tried SELECT INTO and creating the table on the fly, but that doesn't work either.

  2. #2
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    Remove the * and replace it with column names and see if that makes any difference (note you'll have to list out the destination columns too!)

    Also, I note you've mixed double and single quotes in your WHERE clause, is this correct - if so, very odd!?
    George
    Home | Blog

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •