Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2008
    Posts
    20

    Unanswered: mysqldump turn off backquotes

    How to turn off the backquotes enclosed on table name and field name with mysqldump? Some modeler software do not like those backquotes. thanks,

  2. #2
    Join Date
    May 2008
    Posts
    17
    Quote Originally Posted by lmei007
    How to turn off the backquotes enclosed on table name and field name with mysqldump? Some modeler software do not like those backquotes. thanks,
    Uncheck the box under structure that says "Enclose table and field names with backquotes"

  3. #3
    Join Date
    May 2008
    Posts
    17
    Sorry, that was for phpmyadmin

    in mysqldump you can try the

    --skip-quote-names

    option

  4. #4
    Join Date
    Jun 2008
    Posts
    20
    Quote Originally Posted by TonyF123
    Sorry, that was for phpmyadmin

    in mysqldump you can try the

    --skip-quote-names

    option
    it works but not 100%.

    those field names still have quotes on them:
    1. type
    2. status
    3. value
    4. name

    are they the key words? I need to use a different word for them?

    thanks

  5. #5
    Join Date
    May 2008
    Posts
    17
    Quote Originally Posted by lmei007
    it works but not 100%.

    those field names still have quotes on them:
    1. type
    2. status
    3. value
    4. name

    are they the key words? I need to use a different word for them?

    thanks
    not reserverved as far as I know

    It's all a bit strange. I tried it with a table called names that had a field called name in it. Those both had backticks, while none of the other fields did. This was only in the table create bit though. In the insert, neither had backticks. Maybe all you can do for now is get rid of them in a text editor, unless smeone else knows what is going on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •