Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2007
    Posts
    54

    Unanswered: CSS no longer working in php file on unix.

    Please let me know if i've posted in the wrong forum... and I apologize in advance in case I have.

    I've built a site using Apache and PHP. On my local laptop, (which is windows xp professional) everything looks great and my styles are being picked up.
    When i copy my code over to our unix server, none of the styles are being picked up. I know that Unix is case sensitive but the part thats "failing" is the proper case.

    I'm not sure what else I can check for.... here's the code:
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
    "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" >
    <head>
    <title>test.ca </title>
    <meta http-equiv="Content-Type" content="text/html;charset=iso-8859-1" />
    </head>
    <body bgcolor="#FFFFFF" text="#404040" link="#0000FF" vlink="#990099" MARGINWIDTH="1" MARGINHEIGHT="1" TOPMARGIN="1" LEFTMARGIN="1" RIGHTMARGIN="1">
    
    
    
    <link type="text/css" href="style/menu.css" rel="stylesheet">
    <link type="text/css" href="style/gencontent.css" rel="stylesheet">
    And in my gencontent.css, i have the following entry for the BODY tag:

    Code:
    body{
    	list-style: none inside;
    	font-family: verdana, arial, helvetica, sans-serif;
    	background-color: #D2E2F0;
    }
    Last edited by chubbypama; 06-09-08 at 10:28.

  2. #2
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    <link> tags go in the head section, not the body.

    See http://w3schools.com/css/css_howto.asp for more info
    George
    Home | Blog

  3. #3
    Join Date
    Jul 2007
    Posts
    54

    Thanks...but

    that didn't seem to fix / change anything...
    I've put the <link> tags within the <head> but the styles are not being picked up.

    Any other suggestions?

  4. #4
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    Is the path to the CSS files correct?
    Code:
    style/menu.css
    If so, please describe your folder structure.
    George
    Home | Blog

  5. #5
    Join Date
    Jul 2007
    Posts
    54
    georgev,
    I found it - another typo - "genContent.css" as a file name.
    Sorry to have wasted your time.... although you did help me with the tip about the location of the link.
    thanks.

  6. #6
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    Bingo! Thanks for sharing your resolution and glad I could have been of some help
    George
    Home | Blog

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •