Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2005
    Location
    Graz / AUT
    Posts
    9

    Red face Unanswered: starting Informix 10.00TC8 ???

    hi,

    after working with IFX 10TC8 on WindowsXP (demo-notebook)
    for several month, suddenly the
    "Informix IDS"-services can't start with following message:

    "ol_myserver: listener-thread: err = -25572: oserr = 0 (somtimes oserr=13)
    errstr = Network driver cannot bind a name to the port."

    turbo is set to 1526/TCP in the service-file.
    checking netstat: no access/binding to port 1526.

    the only thing i had tried some days before was connecting via odbc to another informix-server on an other machine through the port 1526.

    has someone an idea to help solving my problem ?
    thx
    erik

  2. #2
    Join Date
    Nov 2004
    Posts
    143
    Hello,

    It seems that the port Informix is trying to open is being used by some other application.
    Change the port number in services file and use that port to start Informix.

    Nitin

  3. #3
    Join Date
    Jul 2005
    Location
    Graz / AUT
    Posts
    9
    hi,

    i`ve tried to change the port number to 1527 (also 3333) in the service file, reboot the computer, but nothing changed.
    how can i change the port/name when starting informix (i only typed in the portname when installing it) ?

    thx
    erik

  4. #4
    Join Date
    Nov 2004
    Posts
    143
    Hi,

    Open the services file create a new entry with new port number. Also give a new name to the service. Then use the same name in your $INFORMIXDIR/etc/sqlhosts file. Then try to bring Informix up.

    Nitin

  5. #5
    Join Date
    Jul 2005
    Location
    Graz / AUT
    Posts
    9
    hi,
    this is a windows installation; there is no sqlhosts.
    i also tried to find the serviceport/name in the files of my
    INFORMIXDIR -> no result.

    any other ideas ?
    thx
    erik

  6. #6
    Join Date
    Apr 2007
    Location
    Jundiai / SP - Brasil
    Posts
    311
    The SQLHOSTS on the windows machine stay in the register.
    I do'n work with IDS for windows a few years... but , what I remember you can change the values of SQLHOSTS with SetNet32 program or manually on the register.

    Does you changed the IP of your machine?
    Probably there are some differ between the hostname/IP configured in SQLHOSTS and the configuration of your Windows.
    ________________________________________
    César Inacio Martins
    Jundiai / SP - Brasil
    http://www.imartins.com.br/informix - em Português
    http://www.imartins.com.br/informix - English (translated by Google).
    ________________________________________

  7. #7
    Join Date
    Jul 2005
    Location
    Graz / AUT
    Posts
    9

    Talking


    great !!!!

    it seems that because of the odbc-driver the registry-entry of the local
    machine has changed.

    i just had to change the host-entry of my local machine (in the registry, because setnet has not made the changes) and everything works fine.

    thanks a lot
    erik

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •