Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2004

    Unanswered: Catalog on server troubles

    $ oslevel
    $ db2level
    DB21085I Instance "lacdb2" uses "32" bits and DB2 code release "SQL08023" with
    level identifier "03040106".
    Informational tokens are "DB2 v8.1.1.96", "s050811", "U803920", and FixPak
    Product is installed at "/usr/opt/db2_08_01".
    Dear all,

    Had to remove the sqldbdir files as sqldbdir was corrupted and could not connect to DB at all (wrong version error)

    Trying to rebuild the DB directory and having some troubles. Much searching resulted in finding the following on IBM site regarding cataloging troubles:

    Local fix
    Fix the cataloging, for example:
    db2 uncatalog db test
    db2 catalog db test as testdb
    db2 catalog db testdb as test at node local

    I tried mimicing the above and it worked for the first database--I was then able to connect locally on the AIX server and remotely from a Windows client after re-cataloging using Config Assist.

    So, I thought all was good and I would just UN/Catalog the rest of the DBs on this AIX server. Well, not working anymore.

    When I do the "db2 catalog db NEXT as NEXTDB" it complains that:
    SQL6028N Catalog database failed because database "DCUDB8" was not found in the local database directory.

    Output of db2 list db directory is the following, showing the first DB that worked just find with the UN/Catalog steps above :
    System Database Directory
    Number of entries in the directory = 3
    Database 1 entry:
    Database alias = FIRST
    Database name = FIRSTDB
    Node name = LOCNODE
    Database release level = a.00
    Comment =
    Directory entry type = Remote
    Catalog database partition number = -1
    Alternate server hostname =
    Alternate server port number =

    Database 2 entry:
    Database alias = FIRSTDB
    Database name = FIRST
    Local database directory = /local/db2homes/lacdb2
    Database release level = a.00
    Comment =
    Directory entry type = Indirect
    Catalog database partition number = 0
    Alternate server hostname =
    Alternate server port number =

    Any thoughts on why the Un/Catalog 3 step process not working for subsequent DBs after the first worked so well?


  2. #2
    Join Date
    Dec 2004

    Got tired of trying to outsmart db2 CATALOG and just restored the "sqllib/sqldbdir" directory.

    Back to being operational.

    Last edited by bagofur; 06-27-08 at 09:25.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts