Results 1 to 7 of 7

Thread: Sql1072c!!!

  1. #1
    Join Date
    Feb 2008

    Unanswered: Sql1072c!!!


    I am using "DB2 v8.1.1.120" FP13 on AIX

    I was tring to connect to database. but the command were going in hang state. so i desided to restart the instance.

    Here i am facing a problem in starting the instance.

    i will explain steps i followed to restart the server:

    1) Force application all:[10-20 appli were connected]
    applications were not get foeced. i tried 3-4 times.
    2) db2stop force:
    Now this command get hanged.
    3) db2_kill:
    after wating for an half hour. i tries db2_kill. it ran successfully.

    4) db2start:
    Now here i am facing the problem.

    $ db2start
    07/07/2008 07:37:49 0 0 SQL1072C The database manager resources are in an inconsistent state. DB2 may have been incorrectly terminated, or another application may be using system resources in a way which conflicts with DB2's use of system resources. System resource cleanup may be required.
    SQL1032N No start database manager command was issued. SQLSTATE=57019

    i found [by command "ipcs"] few processes are in zombie state(marked as "D").

    i tried to remove them using ipcrm. but doesn't worked.

    I have faced this problem 2-3 times and resolved by restarting m/c physically.

    Now i don't want to restart the machine. B'coz there are many instances are running on this machine.

    Please suggest!
    Last edited by prashant44; 07-07-08 at 02:31.

  2. #2
    Join Date
    May 2003
    Did you try ipclean?
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  3. #3
    Join Date
    Feb 2008
    No i have not tried it. Even i don't have any idea abt "ipclean" & its consequences. Should i try it now? what will be effects of this?

  4. #4
    Join Date
    Mar 2008
    kill all process for each instance on that server....and then again start all will work...i faced once this.....
    Pawan Kumar

  5. #5
    Join Date
    Feb 2008
    No Pawan..., it is not working!
    It giving the same tipe of error.

  6. #6
    Join Date
    May 2007
    somewhere in dbforums
    Try the 2 options which bailed me out a couple of times

    1. did you try out the ipclean command ipclean instancename

    2. If that does not work then in the sqllib file there is a '.ftok' file. Backup the same and then do 'touch .ftok' and then restart the instance

  7. #7
    Join Date
    Feb 2008
    I have tried this also. It is not solving the problem.

    Please suggest any other way.

    Please reply!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts