Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2008
    Posts
    7

    Unanswered: Replication not working no errors given

    Hi All

    Absolute newbie and just starting out on SQL server.

    I basically got the following

    Remote server A and local server B. I want to replicate data from A to B
    Remote server A is both the Publisher and the Distributor
    They are SQL server 2000 and 2005


    Under replication -> Local Publication I created a publication entry. Under that same publication entry I created a subscription.

    In the Rep. Monitor is shows Uninitialized subscription under the status bar for my subscription. I tried a trace token too and it is in pending state (i.e. from Distrubutor to Subscriber)

    Its seems like its not connecting however when I look at the Warning/ Agents tab it shows as Snapshot agent completed and Log reader agent running.

    Someone did mention that there is no proxy set up between the 2 servers and the prev DBA managed to get it to work OK.

    Any Suggestions folks


    My humble thanks in advance.
    Last edited by Syed Kazmi; 07-14-08 at 12:41.

  2. #2
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Your publication is maybe setup, but your subscription looks suspicious. If you're subscribing from B, why are you setting up subscription on A?
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  3. #3
    Join Date
    Jul 2008
    Posts
    7
    I used an existing example and hence set it up on A . However if I take a look at Server B there is an entry in there which corresponds to the one i created on Server A.

    I did not create that one so it must have got copied over somehow.

  4. #4
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    But your requirement states differently:
    Quote Originally Posted by Syed Kazmi
    I want to replicate data from A to B...
    you need to drop the subscription on both A and B, and then set it up on B to the new publication on A.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  5. #5
    Join Date
    Jul 2008
    Posts
    7
    Many many thanks rdjbarov.
    It is now initialized and both the Snapshot Agent run OK and the Log Reader Agent is now in a running state.

    However just to test it further I tried puting in a trace token and it failed.
    Error message was
    "The process could not read file C:\....\..\..\ReplData\unc\my publisher\table_name" due to OS error 3

    Any clues on this.
    Is it becuase it can't find the correct path on the publisher for the files that need to be replicated. Could be the distributer is not sending the files to the location, how can i check and correct this. I have access to distributer maybe I need to set that side up as well? if so how?
    Last edited by Syed Kazmi; 07-15-08 at 06:39.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •