Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2006
    Posts
    4

    Unanswered: Problem with error 7221 - Failed to connect

    I have an error 7221 problem.

    Situation:
    Win 2003 server
    Adaptive Server Enterprise/12.5.0.3/EBF 11449 ESD#4/P/NT (IX86)
    2 database on this server:
    db_x = local,
    db_y = remote
    server is known as A and B, both names are present in sql.ini
    sql.ini has both db_x and db_y present (portnos correct)
    Configuration ASE: allow remote access =1, no remote conns = 25, no remote sites = 25

    Problem:
    Preforming the following:
    -- step 1 execute
    Use db_x
    go
    -- ok

    -- step 2 execute
    connect to db_y
    go
    -- passthru

    -- step 3 execute
    use db_y
    go
    -- ok

    --step 4 execute
    exec dbo.sp_naam
    go
    -- error 7221 Connect to db_y failed
    -- same error the application gets, which has to be resolved

    No preforming the following:
    --Step 1 execute (as one)
    Use db_x
    go
    connect to db_y
    go
    use db_y
    go
    exec dbo.sp_naam
    go
    -- returns x rows (no error! )

    I checked the following:
    select @@servername ==> correct (=A)
    sp_helpremotelogin had no login ==> but same as on the production machine, which works fine with the application (no errors there).
    configuration allow enough and the right things.
    Interface file has everything ok (as far as I can tell)
    The receiving db is not in single-user mode
    The password is correct

    I really don't know what to check else? Anyone any suggestions?

  2. #2
    Join Date
    Jun 2006
    Posts
    4

    Found a solution

    Did a full checkup of the system and finally found the solution.
    CIS RPC handling was still at 0.
    Setting it to 1 solved the problem!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •