Results 1 to 12 of 12
  1. #1
    Join Date
    Aug 2008
    Posts
    8

    Unanswered: [Microsoft][ODBC SQL Server Driver]Timeout expired

    cannot connect to my sql server 2000
    error
    [Microsoft][ODBC SQL Server Driver]Timeout expired

  2. #2
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    Can you connect with Query Analyzer?

  3. #3
    Join Date
    Aug 2008
    Posts
    8

    hi!

    i just installed win2k server and i install sql 2000 server enterprise and configured all the necessary configuration Data Sources (ODBC) etc. and also restored my existing database, in win2k server the database is already running & theres no problem, but in my winxp workstation i can't access the database & when i go to Data Sources (ODBC) and create new data sources to sql this error appear:

    Microsoft SQL Server ODBC Driver Version 03.85.1132

    Running connectivity tests...

    Attempting connection
    [Microsoft][ODBC SQL Server Driver] Timeout Expired

    TESTS FAILED!



    pls help i am new in this....

  4. #4
    Join Date
    Aug 2008
    Posts
    8

    Smile Cannot Connect to SQL Query Analyzer

    Cannot Connect to SQL Query Analyzer

    Error!!!

    SQL Query Analyzer

    Unable to connect to server SERVER:

    Server: Msg 17, Level 16, State 1
    [Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]SQL Server does not

    exist or access denied.

    Tnx n advance..

  5. #5
    Join Date
    Aug 2008
    Posts
    8

    Additional Info!

    server = win2k sp4 advanced server
    sql ver = sql server 2000

  6. #6
    Join Date
    Aug 2008
    Posts
    8

    Help!!!

    Nid ur help guys so much...

  7. #7
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    Run cliconfig.exe, and change your default network library to Named Pipes to see if that helps. If it does not, change it back.

  8. #8
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Check the firewal settings on the server. Also, review the entries in the current SQL Errorlog and see if the server is listening on TCP port. See what port is being reported, and if it's other than 1433, note the value. Then from your client specify the port number after a comma.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  9. #9
    Join Date
    Aug 2008
    Posts
    8

    no effect...

    theres no effect even i changed named pipes to tcp, i also turned off the firewall in my client computer..

    any idea how to force named pipes to be used instead of tcp? coz in my old system with win2k server they used named pipes...

  10. #10
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    precede the instance name with "np:" without quotes.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  11. #11
    Join Date
    Aug 2008
    Posts
    8

    Where?

    Where can I put the np: can u give me the steps how to do it?? and wat machine the server or the client?? tnx for the reply..

  12. #12
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    You put it in the connection dialog box of Query Analyzer.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •