Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2008
    Posts
    2

    Unanswered: problem with encoding

    There is a db2 server : DB2 OS/390 8.1.0,

    procedure, that simply inserts data into table ins_prib_k('PR','657803','A','3030030',5,1100,'20' ,'1',2111,'З717818','864300','242005','100001','13 134131','05','1222',' ','ОАО СинтеЗ')

    One of the parameters contains cyrillic letters('ОАО СинтеЗ').

    In case procedure is called from .net WebService using DB2Command object, cyrillic letters get into db in form like : 'ОАО СинтеЗ'

    If i call the same procedure from IBM DB2 client, or from other client (for example Quest Central for DB2), everything is fine.



    what is the problem ?

  2. #2
    Join Date
    Sep 2004
    Location
    Belgium
    Posts
    1,126
    Quote Originally Posted by Marvin_ru
    'ОÐ�О СинтÐ& #181;З'
    This is clearly an UTF-8 issue: read in groups of two, except for the space, the above are the 9 two-byte UTF-8 encodings for the Cyrillic text 'ОАО СинтеЗ' to be inserted.
    So in this case apparently the server received the correct bytes, but did not interpret them as UTF-8 as it should have done.
    Verify the communication settings between your client (.net) and the server, and make sure it is set to UTF-8 (unicode).
    (Sorry, I don't know anything about dotnet, so I cannot be of any more help...)
    Last edited by Peter.Vanroose; 08-15-08 at 18:15.
    --_Peter Vanroose,
    __IBM Certified Database Administrator, DB2 9 for z/OS
    __IBM Certified Application Developer
    __ABIS Training and Consulting
    __http://www.abis.be/

  3. #3
    Join Date
    Aug 2008
    Posts
    2
    I tried to convert procedure call to different encodings. No luck.

    Tried to find DB2Command or DB2Connection properties, related to encoding; Still no luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •