Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2005

    Unanswered: problems with db2 catalog/restore

    Some background -
    Last night I applied fix pack 16 for db2 8.1. My current version was and the new version was Needles to say my application had problems and I was informed by the vendor that they only support upto fix pack 12. I restored the system with the mksysb I took prior to the upgrade, but now I am having problems with the database not being catalog etc. I tried to do a list db directory on <path> and received the following error:
    SQL10004C  An I/O error occurred while accessing the database directory.
    I did a list db directory and that did return information including the local database directory for the db that I am having trouble with.

    I thought I could do a restore, but I am getting similar errors. Could anyone please help me get my databases back to normal. Thank you.

  2. #2
    Join Date
    Jul 2005
    I guess what I am asking is what would be the best way to get this database restored and cataloged in the same directory. Thank you.

  3. #3
    Join Date
    Apr 2006
    Provided Answers: 11
    if you have a backup, you could remove the file below sqllib/instance/SQLNODIR
    and restore db or try catalog db on /xxx
    there seems to be a problem with the file
    Best Regards, Guy Przytula
    Database Software Consultant
    Good DBAs are not formed in a week or a month. They are created little by little, day by day. Protracted and patient effort is needed to develop good DBAs.
    Spoon feeding : To treat (another) in a way that discourages independent thought or action, as by overindulgence.
    DB2 UDB LUW Certified V7-V8-V9-V9.7-V10.1-V10.5 DB Admin - Advanced DBA -Dprop..
    Information Server Datastage Certified

  4. #4
    Join Date
    Jan 2007
    Jena, Germany
    I know my answer is not addressing your question, but if you have problems with a newer FixPak, it would mean something is not backward compatible and you should try to figure out what caused the regression. In other words, FixPaks shouldn't break anything that has been working before.
    Knut Stolze
    IBM DB2 Analytics Accelerator
    IBM Germany Research & Development

  5. #5
    Join Date
    Mar 2006

    We faced somewhat similar issues when restoring db. We then restored the backup with re-direct option - ( new db name, new catalog entries..). This seem to fix our issues.

    Our Db2 runs on windows 2003. We also noticed if we login using windows terminal services session and dropped a DB, we have to log out and login back an dthen perform restore. Terminal services session seem to hold on to resources and drop and restore under same Terminal service login session gave an error message similar to the one you have mentioned.


    Hari kumar
    Last edited by sundaram; 08-24-08 at 18:44.

  6. #6
    Join Date
    Jul 2005
    Thank you for your responses. I ended up contacting IBM support and they talked me through what I had to do. We ended up doing what przytula_guy suggested and that worked. Stolze, you are correct that the application does not work with Fixpack 16. I also ended up doing a oslevel restore to get back to my previous release. I will do more research the next time I decide to do an upgrade. Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts