Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2008

    Unanswered: Execute permission denied on sp_runwebtask mssqlsystemresource

    Hi All,
    Hopefully someone can help me with an issue i am trying to resolve.
    I have a client with a NET Framework 2.0 , SQL 2005 application.
    When opening they get the error message as follows:-
    'The EXECUTE Permission was denied on the object 'sp_runwebtask',database 'mssqlsystemresource', schema 'sys'

    I have tried to apply permissions via the master database for the specific NT User and also the internal SQL server user being called,
    no luck.
    I am unable to set permissions on the MSSQLSYSTEMRESOURCE database as this is hidden.
    I assume i need to create a user within mssqlsystemresouce and then assign permissions to it ....but how do i do this??
    Any advice seriously appreciated.

  2. #2
    Join Date
    Feb 2002
    When you changed the permissions - did the error message change?
    If you do not have SQL Server Books Online (BOL) installed - please do so. The majority of questions asked in the SQL Server forum could be eliminated if people had access to bol. BOL

  3. #3
    Join Date
    Sep 2008

    Execute permission denied on sp_runwebtask mssqlsystemresource

    Hi there and thanks for the reply,
    No i have chnaged the permissions on the internal SQL Server user , to have Execute As , and the error message is still the same as before , i have tried a combination of permissions , starting at the highest and working down , all yeild the same error message as before.
    Any more ideas please?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts