Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2008
    Posts
    2

    Unanswered: Can't import Paradox 5 - "External table is not in expected format"

    .
    We cannot import Paradox 5.x tables into MS Access (’97, 2000, or 2003).

    We get the error message “External table is not in the expected format.”

    Background:
    In a large government farm operation, we use a farm management system (FMS) <F-A-R-M-W-O-R-K-S>.

    We also have had for many years a separate MS Access database that imports the Paradox 4.x tables from the FMS for reporting of the accounting data.

    When the FMS recently was upgraded to the newest version, we began having the problem cited above with our Access database. We found that the Paradox tables in the new version of the FMS are now Paradox version 5.x, instead of 4.x.

    What we’ve done:
    Neither I nor my partner in another city can import these new Paradox 5.x tables into any of the three versions of Access, using either WinXP or Win2000, either manually or using code. We get the same error.

    The FMS vendor can import their Paradox 5.x tables into Access 2000 without a problem.

    I can view the 5.x tables in a database viewer without any problem. I see that they are version 5.x and I can view the data in them. There does not seem to be a problem with the tables, themselves.

    OLD / NEW
    • Version number 4.0 / 5.0
    • Header size 72 bytes / 96 bytes
    • Block size 2048 / 2048
    • Sort order ascii ANSI Standard / DBWINUSO 76 (0x4C)
    • File version ID 9 / 11
    • Table level 40 / 50


    The sort order is different between the old 4.x tables and the new 5.x tables. Previously, the 4.x were ‘ascii ANSI Standard,’ and currently, the 5.x tables are ‘DBWINUSO 76 (0x4C)’. I don’t know if this or any of the other differences listed might be important.

    I have removed and reinstalled the MS Access database import components.

    I have unregistered and re-registered three different versions of the MSPDOX35.DLL, that translates external Paradox tables to Access and back.

    I have upgraded MSPDOX35.DLL to the newest version I could find - 3.51.623.0.

    MS Access appears to recognize Paradox version 5 tables, since it offers an option to export Access tables to Paradox 5 (and 7). However, when I open the exported table in the viewer, it shows that it is actually Paradox 4.0.

    The FMS support folks have put some time into testing this problem, but they don’t have any problem, so there’s not much else they can do.

    Can anyone here think of anything that might resolve this problem importing Paradox 5 tables into MS Access?

    Thanks for your help.

    GovDev
    Trip

  2. #2
    Join Date
    Sep 2008
    Posts
    2
    I registered MSPBDE40.DLL and A0004058.DLL with regsvr32.exe and still getting the same error message.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •