Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2003
    Posts
    1,605

    Unanswered: Getting "DBI1309E System error" when db2set command is executed

    Hi,
    on DB2 v9.5 for Linux. DB2 was working well as locally as remotely. But something has changed and db2set command does not display DB2COMM parameter that is required to access db2 remotely. Locally DB2 works fine without any error.

    So I tried to execute command:
    Code:
    db2set DB2COMM=TCPIP
    and got error:
    =========
    DBI1309E System error.

    Explanation:

    The tool encountered an operating system error.

    User response:

    A system error was encountered during registry access. Ensure that there
    is enough space on the file system where the registry is located, and
    that there is a valid LAN connection if the registry is remote.
    =========

    I have checked disk is not full and computer can be accessed by ping command locally and remotely.

    Any idea what is wrong?
    Thanks,
    Grofaty

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    See if ~/sqllib/profile.env is accessible to the instance owner and not corrupted (it should be a regular ascii text file).
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Mar 2010
    Posts
    1

    Needed to be root

    I tried this command from the db2inst1 user, but it only seemed to work for me when I was root. (The profile.env file was fine.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •