Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2008
    Posts
    6

    Unanswered: Not able to find the instance

    Hi,

    On Windows, I installed DB2 v9 COPYs on Machine A, for example DB2COPY1 and DB2COPY2.
    Then I made DB2COPY2 as the default copy using db2swtch.

    Next, from Machine B, I used Control Center to discover databases on Machine A.Only instances/databases in DB2COPY1 were listed on the ControlCenter.
    But I would like to list instances/databases DB2COPY2 has.

    Could you let me know if any other configuration should be set to discover instances/databases in DB2COPY2 by Control Center?

    TCP/IP Service name (SVCENAME) = db2c_DB2_01
    Discovery mode (DISCOVER) = SEARCH
    Discover server instance (DISCOVER_INST) = ENABLE

    TCP/IP Service name (SVCENAME) = db2c_DB2
    Discovery mode (DISCOVER) = SEARCH
    Discover server instance (DISCOVER_INST) = ENABLE


    Thanks

  2. #2
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    I don't know about Control Center, but you can type in this command to see the instances once your attached to at least on of the instances:

    db2ilist
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  3. #3
    Join Date
    May 2007
    Location
    somewhere in dbforums
    Posts
    221
    Something you can check out on...

    In machine A for DB2COPY2 do db2set -all.

    Check whether you have the following parameter set
    [i] DB2COMM=TCPIP
    where i = instance level

    If not then set it to TCPIP by executing the following command -
    db2set DB2COMM=TCPIP

  4. #4
    Join Date
    Apr 2008
    Posts
    39
    Can you try the following:

    Attach to instance on copy2 and do the following:

    Enable discover_inst database manager config parameter.
    Enable discover_db database config parameter

    Thanks,
    Madhavi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •