Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2003

    Red face Unanswered: RMAN using question on 10g - Learning it

    On the same server on Linux- I have target and auxiliary databases and O/S is:
    Linux 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:54:53 EST 2006 i686 i686 i386 GNU/Linux

    I have target database "mmqa" as target and in archivelog mode on 10g. When I set ORACLE_SID=mmqa and run

    (mmqa):/oracle/product/admin/RMAN10> rman target /

    Recovery Manager: Release - Production on Fri Nov 14 12:06:01 2008

    Copyright (c) 1982, 2005, Oracle. All rights reserved.

    connected to target database: MMQA (DBID=969575723)


    I have created by standard methods a database to clone RMAN10 and modified parameters to reflect RMAN10 values. I also created tnsnames.ora and listener.ora values for RMAN10 as

    RMAN10 =
    (ADDRESS = (PROTOCOL = TCP)(HOST = LinuxDB)(PORT = 1521))
    (SID = RMAN10)
    In RMAN10 environment I did

    orapwd file=$ORACLE_HOME/dbs/RMAN10 password=secret entries=10

    I started the RMAN10 instance in NOMOUNT mode with SQLPlus as sysdba.

    I could connect to SQLPlus as

    sqlplus '/ as sysdba' in RMAN10 environment and checked the instance values as "not mounted"

    When I execute the command, I get the error as below ( auxiliary can not be connected ).

    (mmqa):/home/oracle> rman target / auxiliary sys/secret@RMAN10

    Recovery Manager: Release - Production on Fri Nov 14 12:13:35 2008

    Copyright (c) 1982, 2005, Oracle. All rights reserved.

    connected to target database: MMQA (DBID=969575723)
    RMAN-00571: ================================================== =========
    RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
    RMAN-00571: ================================================== =========
    RMAN-00554: initialization of internal recovery manager package failed
    RMAN-04006: error from auxiliary database: ORA-12528: TNS:listener: all appropriate instances are blocking new connections

    I am unable to proceed further for copy the target to auxiliary database. How can I fix this issue? Any help is appreciated.

    Thanks, Vinnie

  2. #2
    Join Date
    Jun 2003
    West Palm Beach, FL

    Talking The other way

    Try the other way around:
    $ export ORACLE_SID=RMAN10
    $ rman <<ERM
    connect target sys/secret@mmqa
    connect catalog rman/rmanpw@rmancat
    connect auxiliary /
    # -- etc ---
    The person who says it can't be done should not interrupt the person doing it. -- Chinese proverb

  3. #3
    Join Date
    Jan 2003

    Thumbs down Tried the suggestion

    Took so long to try, sorry. Tried it but got the same error as described in the issue details. Any other suggestions?

    Thanks, Vinnie

  4. #4
    Join Date
    Jul 2003
    orapwd file=$ORACLE_HOME/dbs/orapwSID password=password entries=10

    To start RMAN and connect to the target and auxiliary instances:

    Start the RMAN client.

    For example, enter the following command at the operating system prompt:

    % rman

    At the RMAN prompt, run CONNECT commands for each database instance.

    In this example, a connection is established to three database instances, all through the use of net service names:

    RMAN> CONNECT TARGET SYS@prod # source database

    target database Password: password
    connected to target database: PROD (DBID=39525561)

    RMAN> CONNECT AUXILIARY SYS@dupdb # duplicate database instance

    auxiliary database Password: password
    connected to auxiliary database: DUPDB (not mounted)

    RMAN> CONNECT CATALOG rman@catdb # recovery catalog database

    recovery catalog database Password: password
    connected to recovery catalog database
    - The_Duck
    you can lead someone to something but they will never learn anything ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts