Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2008
    Posts
    1

    Unanswered: Access 2002-"Property Not Found" Error. Importing .csv into an existing table.

    Hi there!

    Okay, so I run a great deal of reports with access.
    I have Multiple data bases all linked up too each other (Have done this as the amount of Data I'm working with is just so big. This was set up before I arrived in my current job- but I am told that seperating these massive tables will help things run much faster).

    Also- it's probably important for me to mention that all the work I do, should be done with SQL. But work won't buy a devoted server so we've had to make do with getting the same result using expressions (REALLY BIG, detailed expressions). I'd worked with Access prior too this- and I'd never seen anything quite like what I work with now .

    Either way. So I have a table that I created almost a year ago. I use it weekly. I cut and paste data out of a program we use and save this file as a .csv I remove all quotation marks ("), commas (,) and any nulls.

    I simply go into my "Other Tables" data base, find my appointent table copy, paste and then rename it. Thus giving me an empty table ready to import too.
    I import my .csv straight into that table. This has worked on a weekly basis for almost a year. I've never had a problem with it.

    This week, I've had the same problem for a number of tables (all of which, I go through the same process of copy, paste, rename import) and yesterday I started getting this "property not found" error. There is no error number, and the error pops up before it even tries too import. I'm not doing anything differently.

    So I decided- I should test the data! I could have done something wrong. If I import too a new table- it imports fine. And the data looks fine.

    I don't understand what the error is telling me to try and fix what ever the problem is. I've tried googling the error, and because I don't have an error number to go off- I haven't been able to find much.

    So! What does the property not found error mean? What could have gone wrong?

  2. #2
    Join Date
    Oct 2004
    Location
    Melbourne, Australia
    Posts
    201
    If you only use this tale in read-only mode, why not link it directly to the database, where it will appear as a table. I use Excel in much the same way. All you have to do is to make sure that the first line contains the table names. When you are finished with it, simply break the link and renew it with the next weeks data. The linking process activates a wizard which allows you to specify data types, etc.
    This might avoid any problems potentially arising from duplicating a table with copy/paste.

  3. #3
    Join Date
    Nov 2007
    Location
    Adelaide, South Australia
    Posts
    4,049
    Sounds like it might be a case of corruption. Have you tried compact and repairing the database?
    Owner and Manager of
    CypherBYTE, Microsoft Access Development Specialists.
    Microsoft Access MCP.
    And all around nice guy!


    "Heck it's something understood by accountants ... so it can't be 'that' difficult..." -- Healdem
    "...teach a man to code and he'll be frustrated for life! " -- georgev

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •