I'm having a problem with French special characters in my XML file. It seems that MS-Access 2003 uses the ANSI character set. With a click of a button on my form I want English and French XML files to be generated for use by an ASP web page.

The English is fine. The French special characters are not recognized, causing the ASP to show error messages.

Here is a bit of my code:

' Open files for output.
' English files
Open "tdd-EN.xml" For Output As #1
Open "tdd_links-EN.xml" For Output As #2

'French files
Open "tdd-FR.xml" For Output As #3
Open "tdd_links-FR.xml" For Output As #4


'Print the XML heading info
StrTemp1 = "<?xml version=""1.0"" encoding=""UTF-8"" standalone=""yes""?>"
' Debug.Print StrTemp1
' StrTemp1 = Chr(34)
Print #1, StrTemp1
Print #2, StrTemp1
Print #3, StrTemp1
Print #4, StrTemp1

StrTemp1 = "<documents xmlns:xsi=""http://www.w3.org/2001/XMLSchema-instance"">"
Print #1, StrTemp1
Print #2, StrTemp1
Print #3, StrTemp1
Print #4, StrTemp1

' Query the WO records....


strSQL = "SELECT Work_Order_ID, Work_Order_Number, Previous_Work_Order_Number, CBSA_Work_Order_Number, TDD_Name, TC_Forum_From_Date, TC_Forum_To_Date, Web_Notes_English, Web_Notes_French, ASC_TC_Sent_Date, ASC_TC_Approval_Date, Path_Link AS J_Drive_Path, TDD_Path, TDD_PDF, Status, French_Status "
strSQL = strSQL & "FROM Paths_Ref INNER JOIN (Work_Orders INNER JOIN Statuses_Ref ON Work_Orders.Status_ID = Statuses_Ref.Status_ID) ON Paths_Ref.Path_ID = Work_Orders.J_Drive_Path_ID "
strSQL = strSQL & "WHERE (((Work_Orders.Approved_To_SIG)=True))"



Set rstWO = dbsWOT.OpenRecordset(strSQL, dbOpenSnapshot)

rstWO.MoveFirst
' and loop through them to create the documents
Do
StrTemp1 = "<design>"
Print #1, StrTemp1
Print #3, StrTemp1
StrTemp1 = "<workorder>"
Print #1, StrTemp1
Print #3, StrTemp1
If IsNull(rstWO!Work_Order_Number) Then
StrTemp1 = "<actual> </actual>"
Else
StrTemp1 = "<actual>" & rstWO!Work_Order_Number & "</actual>"
End If
Print #1, StrTemp1
Print #3, StrTemp1
......


What can I do to fix this?

Thanks,

Mike