Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2005

    Unanswered: Problem updating config files


    I now have to support IBM Informix Dynamic Server Version 9.40.FC8XC

    Have a developer that is using a nickname from db2 UDB db to delete records from ids db. First he was getting ISAM -134 which I resolved by increasing the number of "Maximum number of locks" in the onconfig.fnd file.

    Now new problem ISAM -12204. Which points to not enough log files. I am trying to increase LOGFILES parm and after the bounce it goes back to where it was.

    What am I missing here? Why does it revert back and what does and how do I make it stick?

    Thank you.
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows

    DB2 v9.7.0.6 os

  2. #2
    Join Date
    Dec 2003
    North America
    I'm not sure what the LOGFILES parameter in the onconfig file does (or does not) do for you but you need to use the onparams command to add log files.

    Something like onparams -a -d your_dbspace_name -s log_file_size <cr>

  3. #3
    Join Date
    Nov 2008
    Provided Answers: 1
    When you are doing some operation which changes data in database for which is logging turned on, then every change on data is also recorded in "logical log". If you are doing lots of changes within a transaction, then there should be enough "logical log" space to accomplish whole transaction.

    If you execute only one delete statement (without explicit starting transaction - i.e. "begin work"), then delete statement is transaction. If delete statement deletes lots of data, then all deleted data should fit in "logical log". So, if you execute delete statement on lots of rows, you can reach end of logical log space. What you can do: you can add more logical log space (what mjldba suggested) or you can delete multiple times smaller set of rows.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts