Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2008
    Posts
    16

    Unanswered: SQLCMD very slow

    I started running some SQL scripts through SQLCMD instead of the Studio and found that these now execute very slowly. I'm on a MSSQL 2005 server. I have no benchmarks but I estimate something like 4 X slower. I now wait 1 hour instead of 15 minutes for one of these scripts to finish. Also I note that only one of my 8 cpus is running the script i.e. at 13% load. Anyway to speed this up?

  2. #2
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    Compare the connection settings for SQLCMD, and SQL Management studio. I believe SQLCMD does not default to QUOTED_IDENTIFIERS =ON, but SSMS does.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •