Hi to you all.

I have been working on a project to generate a script for a user-specified database object (in SQL Server 7). The application seemed to work well until I tried it out on Windows Vista, where I get the '[SQL-DMO] invalid database-object type' error, and I cannot seem to get anymore info when debugging.

While trying to adress this issue, I installed a MSM file (which is suppossed to install everything that's needed to use SQLDMO) but instead o fixing it, I got the same error in my development machine, which is running Windows XP SP3, so the only thing I've found is that it's not a Vista-related issue and the problem (apparently) has something to do with a DLL or anything that came in tat MSM file that I installed.

I've been trying for several days, using Orca to see which DLLs were included in the MSM file and compare the file version for each one before and after running it to see what could be causing the problem, but so far the only way I can get my PC to work again with the app is to do a System Restore.

This is the code where it crashes:

DBObject dbObjectSQL7 = null;

dbObjectSQL7 = dBDSQL7.GetObjectByName(objA, SQLDMO_OBJECT_TYPE.SQLDMOObj_AllDatabaseObjects, strOwner);

Has anyone else run into this problem? Do you have any ideas that could help me fin what's going wrong?

Any help is appreciated.