Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2009
    Posts
    2

    Unanswered: The LSN (0:0:0) passed to log scan in database

    Thanks in advance for your help...I came in to work one morning and our dialer server was not starting...I then went in to the error log and found

    error:9003 The LSN (0:0:0) passed to log scan in database is invalid.
    and the database showed up in suspect mode.

    Unfortunately we were only backing up the data...which I restored...resulting in the same error.

    I read in another forum that I should detach and attach the database via:

    USE master
    EXEC sp_detach_db 'Test', 'true'
    EXEC sp_attach_single_file_db @dbname = 'Test',
    @physname = 'c:\mssql7\data\Test_Data.MDF'

    which resulted in this error:

    Server: Msg 9003, Level 20, State 6, Line 1
    The LSN (10:1079429312:22448) passed to log scan in database '.f?? ?.????..??..
    TdiXL............................................. .................................................. .................................................. .................................................. .................................................. ....... ...?...............?.....a.....?................. ..........

    Connection Broken
    and now I have no database at all.

    IS THERE REALLY NO WAY TO JUST CREATE A NEW LOG FILE!!!???

    PLEASE HELP!!! THIS IS REALLY STRESSING ME OUT!!!

  2. #2
    Join Date
    Aug 2008
    Location
    India
    Posts
    55
    did u check wat is written in SQL server errorlog (master..xp_readerrorlog ) and then analyse to solve the same .

    if no improvement try running sp_who2 check whether any spid using the mentioned database kill it and try doing the same , Right click enterprise manager and refresh sometime it might have detached and not reflected in MMC

  3. #3
    Join Date
    Feb 2009
    Posts
    2
    thanks for the reply...

    I checked it. The first error was something about being unable to access the log file. The errorlogs have already overwritten the intital error

    Which is why I suspected the log was getting too large...and detached/attached as to shrink the log file...but now it won't attach.

    Server: Msg 9003, Level 20, State 6, Line 1
    The LSN (10:1079429312:22448) passed to log scan in database '.f?? ?.????..??..
    TdiXL............................................. .................................................. .................................................. .................................................. .................................................. ....... ...?...............?.....a.....?................. ..........

    Connection Broken

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •