Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2009

    Unanswered: SQL Problem Please Help


    I'm having some problem with my site. It show me a error like this:

    Microsoft OLE DB Provider for ODBC Drivers error 80004005
    [Microsoft][ODBC SQL Server][DBNETLIB]SQL Server does not exist or access denied.

    /Default.asp, line 8 or 15

    Here's the vbscript:

    <!--#include virtual="/bin/initialize.asp"-->
    dim conn
    set conn = Server.CreateObject("ADODB.Connection")
    conn.ConnectionTimeout = 15
    conn.CommandTimeout = 30
    conn.Open "DSN=aview", "sa", "aud13nc3"

    dim conn1,desc
    set conn1 = Server.CreateObject("ADODB.Connection")
    conn1.ConnectionTimeout = 15
    conn1.CommandTimeout = 30
    conn1.Open "DSN=ticket", "sa", "aud13nc3" - This is Line 8

    dim rs1,sql,rs
    sql = "Select * from tbl_events where featured = 1"- This is Line 15
    set rs1 = conn1.execute(sql)

    I'm Running SQL2000 on the back end.

    Hope you could help me on this, Thanks!

  2. #2
    Join Date
    Dec 2008
    try this in a sp call that sp in ur frontend

    declare @str varchar(64)

    select @str= 'select * from tbl_events where featured = 1'
    print @str

    u have to use single quotes than the double quotes i think so once check

  3. #3
    Join Date
    Aug 2008
    If this error occurs in previously working site or newly created ,
    Related To SQL server , first check whether SQL server services are running fine , authentication mode for SQL is MIXED / Windows , and also check given sa password is working fine if SQL mode is MIXED

  4. #4
    Join Date
    Jun 2004
    As the following line

    conn.Open "DSN=aview", "sa", "aud13nc3"

    produces no error messages, the problem can be linked with the incorrect settings of the second DSN (ticket).
    Complete database management tools for MySQL, SQL Server, Oracle, PostgreSQL, SQLite, Firebird, DB2, and MaxDB.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts