Results 1 to 9 of 9

Thread: have_innodb=NO

  1. #1
    Join Date
    Jun 2007
    Posts
    197

    Smile Unanswered: have_innodb=NO

    hi

    My sysadmin have installed MySQL version: 5.1.30

    when i check
    show variables like '%innodb%';

    i got have_innodb =NO

    i check for my.cnf there no skip_innodb
    when i uncheck any innodb variable
    its give
    Starting MySQL.Manager of pid-file quit without updating file.[FAILED]

    error when i start service

    how to enable innodb

  2. #2
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    talk to your sysadmin.
    if you need INNODB they should make sure its available.
    I'd rather be riding on the Tiger 800 or the Norton

  3. #3
    Join Date
    Jun 2007
    Posts
    197

    Smile

    Quote Originally Posted by healdem
    talk to your sysadmin.
    if you need INNODB they should make sure its available.
    should there would be any service pack installation for MySQL 5.1.30 version

  4. #4
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    dunno
    try searching the mysql site for service packs. I'never isntalled a service pack.. I've updated the servers several times with new versions, but never come accros a service pack.

    If I remember correctly INNODB may be an option on the windows installer.... thats why I suggest you go back to your network trolls and get them to resolve the issue
    I'd rather be riding on the Tiger 800 or the Norton

  5. #5
    Join Date
    Apr 2002
    Location
    Toronto, Canada
    Posts
    20,002
    as far as i know (and i am ~so~ not a DBA) that setting is only your default for when you don't specify an engine, and you can happily create innodb tables simply by ensuring that you name the engine...
    Code:
    CREATE TABLE shoutout
    ( w00t INTEGER 
    , foobar VARCHAR(37)
    ) ENGINE=InnoDB;
    rudy.ca | @rudydotca
    Buy my SitePoint book: Simply SQL

  6. #6
    Join Date
    Mar 2004
    Posts
    480
    innodb is turned off by default in new installs of mysql and many service providers do not allow them.

  7. #7
    Join Date
    Jun 2007
    Posts
    197

    Smile

    Quote Originally Posted by guelphdad
    innodb is turned off by default in new installs of mysql and many service providers do not allow them.
    innodb plugin by default is not open in this edition my system admin explicitly
    open the plugin innobase now its working

  8. #8
    Join Date
    Jun 2007
    Posts
    197

    Smile Problem facing while insert update

    After migrating application from MySQL 5.0.51b version to 5.1.30-log

    When required to update or insert through application following error occur


    Binary logging not possible. Message: Transaction level 'READ-COMMITTED' in InnoDB is not safe for binlog mode

    Is there any idea where could be problem

  9. #9
    Join Date
    Mar 2004
    Posts
    480
    separate question, belongs in a new thread. again the answer will be to ask your sys admin to allow binary logging.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •