Results 1 to 8 of 8
  1. #1
    Join Date
    Feb 2009
    Posts
    3

    Unanswered: DB is up, but onstat says it is down

    Hi.

    I would appreciate your inputs, as I am stumped.

    We are running Informix Dynamic Server Ver. 7.31.TD1X2, supporting a SAP application in a Win2K Advanced Server environment.

    After installing some application plug-ins, I re-started the db yesterday via services.msc. Then I checked that the db was up via onstat - and onstat -m, to ensure there were no errors, before starting the SAP application. The SAP application came up properly, and continues to run w/o any logged errors as of this hour - approx. a day after it was started.

    This morning when I ran onstat -m, the response was:

    "shared memory not initialized for INFORMIXSERVER 'mfcprodmfctcp'..."

    However the SAP application continues to run properly.

    I have checked the onconfig file and environment variables, and everything seems in order.

    I would like to stop/start Informix and SAP to see what happens, but I do not have that luxury as this a production environment and obtaining permission to go offline takes forever.

    Does anyone have any clues why this happened?

    Thanks in advance for any inputs.

    Jaime Gonzalez
    Last edited by vegetablejoe; 02-23-09 at 03:00.

  2. #2
    Join Date
    Feb 2009
    Posts
    51
    Please, give online.log after installation some application plug-ins.
    Anв give output onstat -g dis
    Do not use services.msc!
    You can stop/start server from command line.
    On windows plarform use:
    for start server: starts server_name
    for stop server: onmode -ky

  3. #3
    Join Date
    Jun 2005
    Location
    Santa Fe, Argentina
    Posts
    27
    Seems to be a INFORMIXSERVER value problem. Check te values of INFORMIXDIR, ONCONFIG and INFORMIXSERVER in your environment. If INFORMIXSERVER points to a wrong direction, onstat never could find the engine.

    Post the online.log and the environment off the cmd session, and the sqlhosts values (setnet32).

  4. #4
    Join Date
    Feb 2009
    Posts
    3
    Thank you for your inputs.

    Here is the partial online.log for the date and time Informix was restarted. No alarming log entries have appeared from then to-date.
    -----------------------------------------------------------------------
    11:03:33 Logical Log 34811 - Backup Completed
    11:04:56 Logical Log 34812 Complete.
    11:08:43 Logical Log 34813 Complete.
    11:11:11 Checkpoint Completed: duration was 2 seconds.
    11:11:11 Checkpoint loguniq 34814, logpos 0x1fdff0c

    11:17:23 Logical Log 34814 Complete.
    11:31:24 Checkpoint Completed: duration was 2 seconds.
    11:31:24 Checkpoint loguniq 34815, logpos 0xf3c728


    Sun Feb 22 13:02:41 2009

    13:02:41 DR: DRAUTO is 0 (Off)
    13:02:41 Informix Dynamic Server Version 7.31.TD1X2 Software Serial Number ACN#J179674
    13:02:42 WARNING! LTXHWM (70) and/or LTXEHWM (80) config parameters
    exceed recommended values of 50 and 60. This may
    cause On-Line to wait too long before rolling
    back a long transaction and allow it to completely
    fill the logs. See the Dynamic Server Administrators Guide
    for more information on resetting LTXHWM and LTXEHWM.

    13:02:47 Informix Dynamic Server Initialized -- Shared Memory Initialized.
    13:02:47 Physical Recovery Started.
    13:02:52 Physical Recovery Complete: 8368 Pages Restored.
    13:02:52 Logical Recovery Started.
    13:03:06 Logical Recovery Complete.
    289 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks

    13:03:07 Dataskip is now OFF for all dbspaces
    13:03:07 Init operation complete - Mode Online
    13:03:07 On-Line Mode
    13:03:18 Checkpoint Completed: duration was 0 seconds.
    13:03:18 Checkpoint loguniq 34815, logpos 0x270e018
    -----------------------------------------------------------------------
    At that point in time, 13:03 02/22/09 Sunday, I was still able to use onstat -m, as is my m.o., to check whether the db came up without error, before going on to start the SAP application.

    On 02/23/09 Monday, that is when the onstat - command started replying with "shared memory not initialized for INFORMIXSERVER 'mfcprodmfctcp'".


    rootdbs,

    Sorry but the onstat.exe doesn't reply properly; so no onstat -g dis output available. I have also checked that the informix executables have not been compromised by viruses (using McAfee software).

    services.msc is what the SAP app specifies so that is what we regularly use. Alternatively I have used oninit to start up, but have not tried the starts command. Will try this at the next opportunity.

    I am also familiar with the onmode -yuk command. Thanks!


    gtobares,

    hereunder are the values of the ff. environment variables, as seen via REGEDIT for HKEY_LOCAL_MACHINE\SOFTWARE\SAP\MFC\Environment

    INFORMIXDIR = F:\Informix\MFC
    INFORMIXSERVER = mfcprodmfctcp
    INFORMIXSQLHOSTS = \\mfcprod
    ONCONFIG = onconfig.mfcprod.mfc
    SAPSYSTEMNAME = MFC

    The above values remain the same for the environment variables on the cmd sessions of userids Informix and mfcadm (SAP Admin id).

    --------------------------------------------------------------------------

    Hereunder are the values as per the cmd session of informix:

    ALLUSERSPROFILE=C:\Documents and Settings\All Users
    APPDATA=C:\Documents and Settings\informix\Application Data
    CLIENTNAME=SMITS364
    CLIENT_LOCALE=EN_US.CP1252
    CommonProgramFiles=C:\Program Files\Common Files
    COMPUTERNAME=MFCPROD
    ComSpec=C:\WINNT\system32\cmd.exe
    DBLANG=EN_US.CP125
    dbms_type=INF
    DBTEMP=f:\informix\MFC\infxtmp
    DB_LOCALE=EN_US.8859-1
    HOMEDRIVE=C:
    HOMEPATH=\Documents and Settings\informix
    INFORMIXDIR=f:\informix\MFC
    INFORMIXSERVER=mfcprodmfctcp
    INFORMIXSQLHOSTS=\\MFCPROD
    INFORMIX_DBID=MFC
    LOGONSERVER=\\MFCPROD
    NSR_DATA_VOLUME_POOL=MFC
    NSR_LOG_VOLUME_POOL=MFCL
    NSR_SERVER=networker
    NUMBER_OF_PROCESSORS=8
    ONCONFIG=onconfig.mfcprod.mfc
    OS=Windows_NT
    Os2LibPath=C:\WINNT\system32\os2\dll;
    Path=f:\informix\MFC\bin;F:\usr\sap\MFC\sys\exe\ru n;C:\Program Files\Legato\nsr\bin;C:\WINNT\system32;C:\WINNT;C: \WINNT\System32\Wbem;f:\informix\bin;;f:\informix\ mfc\bin;;
    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WS F;.WSH
    PROCESSOR_ARCHITECTURE=x86
    PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 7, GenuineIntel
    PROCESSOR_LEVEL=6
    PROCESSOR_REVISION=0f07
    ProgramFiles=C:\Program Files
    PROMPT=$P$G
    SERVER_LOCALE=EN_US.CP1252
    SESSIONNAME=RDP-Tcp#25
    SystemDrive=C:
    SystemRoot=C:\WINNT
    TEMP=C:\DOCUME~1\informix\LOCALS~1\Temp\1
    TMP=C:\DOCUME~1\informix\LOCALS~1\Temp\1
    USERDOMAIN=MFCPROD
    USERNAME=informix
    USERPROFILE=C:\Documents and Settings\informix
    windir=C:\WINNT
    ------------------------------------------------------------------------

    Hereunder are the values under Informix Connect setnet32

    [Setnet32]
    Format= 9.30 2.40.TC1
    [ENVIRONMENT]
    CC8BITLEVEL=
    COLLCHAR=
    CONRETRY=
    CONTIME=
    DBANSIWARN=n
    DBDATE=
    DBLANG=
    DBMONEY=
    DBNLS=
    DBPATH=
    DBTEMP=
    DBTIME=
    DELIMIDENT=n
    ESQLMF=
    FET_BUFF_SIZE=
    GL_DATE=
    GL_DATETIME=
    INFORMIXDIR=f:\informix\MFC
    INFORMIXSERVER=mfcprodmfctcp
    INFORMIXSQLHOSTS=\\mfcprod
    LANG=
    LC_COLLATE=
    LC_CTYPE=
    LC_MONETARY=
    LC_NUMERIC=
    LC_TIME=
    DBALSBC=
    DBAPICODE=
    DBASCIIBC=
    DBCENTURY=
    DBCODESET=
    DBCONNECT=
    DBCSCONV=
    DBCSOVERRIDE=
    DBCSWIDTH=
    DBFLTMSK=
    DBMONEYSCALE=
    DBSS2=
    DBSS3=
    IFX_AUTOFREE=
    IFX_DEFERRED_PREPARE=
    NODEFDAC=
    OPTMSG=
    OPTOFC=
    IFX_USE_PREC_16=
    NOZEROMDY=
    [Size]
    CLIENT_LOCALE=0
    DB_LOCALE=0
    NumOfHosts=0
    NumOfServers=1
    NumOfProtocols=9
    ServerSize=15
    HostSize=1
    ProtoSize=81
    [Lists]
    INFORMIXSERVERLIST=mfcprodmfctcp;
    HostList=
    PROTOCOLLIST=olsoctcp;sesoctcp;onsoctcp;olsocspx;o nsocspx;sesocspx;seipcpip;olipcnmp;onipcnmp;
    [__infx_sqlhost_mfcprodmfctcp]
    HOST=mfcprod
    SERVICE=sapinfMFC
    PROTOCOL=onsoctcp
    OPTIONS=x=mfcprodmfctcp
    --------------------------------------------------------------------------

    Thank you again for you help and patience.

    Regards.

    Jaime G.

  5. #5
    Join Date
    Feb 2009
    Posts
    51
    INFORMIXSQLHOSTS = \\mfcprod
    INFORMIXSQLHOSTS=\\MFCPROD

    Is it really needed?
    On windows platform usually this parameter is empty or point to unique sqlhosts file for unique Informix instance.

    SESSIONNAME=RDP-Tcp#25
    Do you use Remote Desktop?
    If you have direct access to server, pls, use it and run onstat -.

    First of all try to use direct access and run onstat -.
    If it will does not work wait folk of this forum.

  6. #6
    Join Date
    Jun 2005
    Location
    Santa Fe, Argentina
    Posts
    27
    One question, you change the "SERVERNUM" in the onconfig? onstat and other utilites use "shared memory" connection method, not "tcp/network" method. SERVERNUM allow to determine the memory direction of the shared memory segments. This is true on unix servers, I will install IDS on my windows server to check somethigs...

  7. #7
    Join Date
    Feb 2009
    Posts
    3
    rootdbs,

    you got it right, sir! I would never have thought to go back and isolate that. Yes, I was logging on from my pc via Remote Desktop Connection while experiencing my problems.

    I went back to the console (another site) and all the informix commands ran ok from there. Belatedly, it seems there are bugs betweeen our level of Informix and remote terminal services.

    Problem solved! Woohooooo....

    Sir, if you are ever in Manila, look me up... I owe you a good meal! I was getting more stressed out as the days went by, because I needed to add chunks to the db soonest. What a relief!

    gtobares,

    Yes, SERVERNUM is changed in the onconfig file. As per readings sent to me, we need to upgrade Informix to a level that is patched to allow the use of Remote Desktop Connection.

    Thanks to you guys again!

    Regards,

    Jaime Gonzalez

  8. #8
    Join Date
    Feb 2009
    Posts
    51
    Quote Originally Posted by vegetablejoe
    rootdbs,
    Sir, if you are ever in Manila, look me up... I owe you a good meal!
    Regards,
    Jaime Gonzalez
    Certainly! I am glad to help you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •