Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2009
    Posts
    1

    Unanswered: 'SQLOLEDB' was unable to begin a distributed transaction

    Hi,
    Iam trying to update a database in one sqlerver from another database which is in another sqlserver using linked server.

    However iam facing an error as below

    [Microsoft][ODBC SQL Server Driver][SQL Server]The operation could not be performed because the OLE DB provider 'SQLOLEDB' was unable to begin a distributed transaction.

    Both machines are using sql server 2000 on windows server 2003 SP2.

    I enabled the network DTC access on both machines but still getting the error.

    Any suggestions are highly appreciated
    .
    Thanks in advance

  2. #2
    Join Date
    Nov 2004
    Location
    Canada
    Posts
    58
    Try downloading DTCPing.exe from microsoft and following the recommended solution from there.

    Some possible reasons this is failing but not verified.
    1. Firewall issues
    2. Triggers
    3. Nested Transactions
    4. Remote login permissions.


    Can you do a simple select to your linked server? Just want to verify you can at least perform that.

    Have you checked your sp_configure advanced options? Ensure that allow updates, remote proc trans, etc are configured properly?

    I once got this error because I put begin transaction and commit transaction in a procedure that i called from a linked server. When I removed it and did a direct update I was fine. Even though I know this was not the true solution. I used this work around.

  3. #3
    Join Date
    Jun 2004
    Location
    Long Island
    Posts
    696
    Control Panel -> Admin Tools -> Component Services -> Component Services -> computers -> Right Click My Computer -> Properties -> MSDTC -> "Security Configuration" Check Allow Inbound and Allow Outbound and "No Authentication Required"

    Make sure account is "NT AUTHORITY\NetworkService"

    Fixed me 99% of the time with servers.

    I had to msdtc -uninstall then msdtc -install to re-install to remedy a couple of times. There is an MS Article that outlines the steps, don't know it off the top of my head at the moment.'' Know you said you enabled, but did you click allow inbound and outbound.

    http://support.microsoft.com/kb/817064
    Last edited by PMASchmed; 04-13-09 at 15:45.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •