Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2009
    Posts
    19

    Unanswered: replication server

    hi all

    when my machine boots ,it automatically starts the dataserver,backupserver , rep server throu the script written in /etc/init.d file .My dataserver & backupserver starts but replication server doesn't get started with this script. Ifyou run this script manually ,it works without any error

    following error gets logged
    Reading 'WS1SYB.WS1REP_RSSD..rs_config' for system configuration parameters.
    E. 2009/04/08 09:58:26. ERROR #31067 GLOBAL RS(GLOBAL RS) - /cfginit.c(3142)
    Using interfaces file 'ct_results returned bad value.'.
    E. 2009/04/08 09:58:26. ERROR #1028 GLOBAL RS(GLOBAL RS) - /cfginit.c(3142)
    Message from server: Message: 921, State 1, Severity 14 -- 'Database 'WS1REP_RSSD' has not been recovered yet - plea
    se wait and try again.

  2. #2
    Join Date
    Feb 2009
    Posts
    19

    replication server

    Always start the data server ,then the backup server and lastly the replication server .
    If the replication server starts before the completion of backup server , error occurs in repserver log and repserver goes down.

  3. #3
    Join Date
    Feb 2007
    Location
    India
    Posts
    56

    Re: replication server

    Hi Anusha,
    I guess as per the above error your RSSD did not came up by the time replication server started. first start your primary ASE server(contains RSSD DB) then backup server then your replication server. This is the sequence. But please put sleep of 5 mins for each and try.


    Thanks & Regards,
    Naveen.
    Regards,
    Naveen.
    Sybase DBA-Consultant

  4. #4
    Join Date
    Feb 2009
    Posts
    19
    thanks Naveen

    The above problem has got resolved . Still i get the following error as my primary machine server starts after the secondary machine server.



    2009/04/29 09:00:48. SQM starting: 104:1 WS2SYB.ncdb
    I. 2009/04/29 09:00:48. DIST for 'WS2SYB.ncdb' is Starting
    I. 2009/04/29 09:00:48. DIST for 'WS2SYB.WS2REP_RSSD' is Starting
    E. 2009/04/29 09:04:32. ERROR #1027 dVERSION(Set version number to 1200) - seful
    /cm.c(2899)
    Open Client Client-Library error: Error: 84083972, Severity 5 -- 'ct_con
    nect(): network packet layer: internal net library error: Net-Lib protocol drive
    r call to connect two endpoints failed', Operating System error 0 -- 'TLI connec
    t call failed - t_errno 9'.
    E. 2009/04/29 09:04:32. ERROR #13045 dVERSION(Set version number to 1200) - sefu
    l/cm.c(2905)
    Failed to connect to server 'WS1REP' as user 'rep'. See CT-Lib and/or se
    rver error messages for more information.
    E. 2009/04/29 09:04:32. ERROR #45 dVERSION(Set version number to 1200) - rpctool
    s.c(673)
    Could not connect to ID Server 'WS1REP'.
    E. 2009/04/29 09:04:33. ERROR #1027 RSI(WS1REP) - seful/cm.c(2956)
    @

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •