Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2009
    Posts
    3

    Unanswered: Disable kKerberos authentication?

    I've got a db2 9.1 FP1 server running on RHAS 4U4. We use this server for development purposes only. We were using it with Kerberos authentication. However our KDC server has died, and I don't have enough time right now to rebuild it.

    Is there a way I can start the db2 server and not have it use Kerberos authentication? When I try to start the db2 server right now, it gives the following error:

    -bash-3.00$ db2start
    SQL1366N A security plug-in "IBMkrb5" processing error occurred on the client. Reason code = "9".


    I'm a neophyte when it comes to db2. Any help would be greatly appreciated.

    Thanks in advance.
    Last edited by kelleybdk; 05-04-09 at 20:47.

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    I think it should be enough to set the srvcon_auth database manager configuration parameter to SERVER.

    db2 update dbm cfg using srvcon_auth server
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Mar 2009
    Posts
    3
    I used the command as you stated.

    db2 => update dbm cfg using srvcon_auth server
    DB20000I The UPDATE DATABASE MANAGER CONFIGURATION command completed
    successfully.


    but when I try to start the server, I still have the same problem.

    db2 => db2start
    SQL1366N A security plug-in "IBMkrb5" processing error occurred on the
    client. Reason code = "9".

    Any other ideas?

    Thank you

  4. #4
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    You could also try setting the srvcon_gssplugin_list parameter to NULL.

    If all else fails, try reading the manual.
    ---
    "It does not work" is not a valid problem statement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •