Results 1 to 4 of 4
  1. #1
    Join Date
    May 2009
    Posts
    13

    Unanswered: Not able to send Mails using SQL Mail

    Hi

    i am not able to send emails in MS Sql server 2000.

    Following are the steps i did while configuring sql mail:
    1. Created one domin account (Administrator)
    2. Login into the system with domain account (OS:Windows Server 2003)
    3. Installed MS Office 2003
    4. Configured one email account with "SQLMailService" as profile name
    5. Opened Enterprise Manager from Start > Programs > Microsoft SQL Server > Enterprise Manager. Next, right-clicked on SQL Server and chosen Properties, then choose the Security tab. Under the Startup Service Account, given the domain account user name and password
    EX: User name: domain-name\
    password: xxxxxxxx
    6.Next expanded SQL Server > Management, then right-click on SQL Server Agent and chosen Properties . On the General Page, under the Service Startup Account given the domain account user name and password. And in the Mail Session given the out look profile name and clicked on "Test", Successfully started ( and stopped) a mail session with this profile message came.
    7. Expanded Support Services folder and clicked on Properties of SQL Mail. Here also given the same Out look profile name and clicked on Test button, Successfully started ( and stopped) a MAPI session with this profile message came.
    8. Expanded Management -> SQL Server Agent, right click on Operators and selected new operator. Here email address given and clicked on Test button immediately one message is coming "This will send the message ---- the group with the address ----- ok to send?. when i clicked on OK,

    ERROR 22022: SQLSERVERAGENT ERROR: THE SQLSERVERAGENT MAIL SESSION IS NOT RUNNING; CHECK THE MAIL PROFILE AND/OR THE SQLSERVERAGENT SERVICE STARTUP ACCOUNT IN THE SQLSERVERAGENT PROPERTIES DIALOG. message is displaying.

    i checked many times that all the services are running.


    can any body plz help me where i did wrong?

  2. #2
    Join Date
    Nov 2004
    Location
    Canada
    Posts
    58
    open query analyzer and do the following
    execute master.dbo.xp_sendmail
    @recipients = 'validemailaddress@whatever.com,
    @subject = 'test',
    @query ='select getdate()'

    then execute hit f5 - do you get an error?

    Then read this if you don't get anywhere with the above.

    ERROR 22022: SQLSERVERAGENT ERROR: THE SQLSERVERAGENT MAIL SESSION IS NOT RUNNING; CHECK THE MAIL PROFILE AND/OR THE SQLSERVERAGENT SERVICE STARTUP ACCOUNT IN THE SQLSERVERAGENT PROPERTIES DIALOG. message is displaying.

    If you receive this error message, first make sure that the SQL Server Agent service is running. To do this, follow these steps:
    Click Start, click Run, type Services.msc, and then click OK.
    In the Services window, locate the SQL Server Agent service.
    Make sure that the value of the Status column of the SQL Server Agent service is Running.
    If the SQL Server Agent service is running, this problem occurs because the SQL Server Agent service cannot interpret the dot mark (.) that represents the local computer in the ObjectName registry entry under the following registry subkey. For a default instance, the registry subkey is as follows:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\MSSQLSERVER\
    For a named instance, the registry subkey is as follows:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\MSSQL$InstanceName\
    Note InstanceName is a placeholder for the instance of SQL Server.

  3. #3
    Join Date
    May 2009
    Posts
    13
    Hi Thankyou for your reply, i checked the SQL Server Agent, it is running. my instance is a named instance. this problem occurs because the SQL Server Agent service cannot interpret the dot mark (.) that represents the local computer in the ObjectName registry entry under the following registry subkey, i could not understand this, can u plz explain this in detail. when i executed the xp_sendmail SP i am getting the following error message:

    xp_sendmail: failed with mail error 0x8004011d

    can u plz assist me to resolve this issue.
    Last edited by venubabu; 05-25-09 at 02:23.

  4. #4
    Join Date
    May 2009
    Posts
    13
    Hi My issue got resolved. earlier my windows login id and exchange server id were in two different domains. now i changed both the ids into one domain. Now i am able to send emails by using xp_sendmail and SQLServerAgent operator.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •