Hi there!

I'm building my own website and by the time being I work on localhost.

When I open it to work in my MySQL DB, phpMyAdmin tells me:
"Your PHP MySQL library version 5.0.77 differs from your MySQL server version 5.1.34. This may cause unpredictable behavior.".
But this warning doesn't prevent me to work on the DB...

What does it means?
How can I change the PHP MySQL library version (because I don't want to install a downgrade of MySQL)?
Could this be the reason why the conf.inc.php file (which is included with all my php scripts) cannot connect to the DB and by the way makes any query execution impossible?

Many thanks in advance for your help!

Best regards,