Results 1 to 3 of 3
  1. #1
    Join Date
    May 2009
    Location
    Darmstadt, Germany
    Posts
    13

    Unanswered: Remove secondary truncation point

    Hello,

    I am working in a replication environment with two servers (ASE 15.0.2) and one replication server (15.0.1) using MSA.

    The two servers contains only one databse which is marked to be replicated and replication works fine.

    Now I am working in the case that the replicated server is completly down (for example due to a catastrophe). I want to stop completly the replication and to delete the secondary truncation point to avoid a filling up from the transaction log.

    I have tried with "dbcc settrunc (ltm, ignore)" and to dump transaction log. In this case, the replication is stopped. Nevertheless, all the transactions that I execute until I set "dbcc settrunc (ltm, valid)" are replicated later on, so that means (I think) that the secondary truncation point is not removed. Otherwise, all the transactions that I execute while the truncation point is set to ignore should be not replicated.

    I have also tried with command "sp_config_rep_agent disable" but also all the transaction that I have executed are later on replicated when the replication agent is enable again.

    My question is: somebody knows a way to avoid the secondary truncation point to work in the transaction log? I want that all the transaction commited by ASE are truncated and never replicated to avoid a filling up from truncation log.

    Thank you in advance!

  2. #2
    Join Date
    Sep 2003
    Location
    Switzerland
    Posts
    443
    Are you sure you used the database when you did dbcc settrunc(ltm,ignore)? You are also missing rs_zeroltm.

    To disable.

    1. dbcc settrunc(ltm,ignore).
    2. sp_stop_rep_agent <dbname> or sp_config_rep_agent 'disable'.

    To enable when you are ready. P.S. The order is very important.

    If you have used sp_stop_rep_agent

    1. dump tran with truncate_only.
    2. use db
    dbcc settrunc(ltm,valid)
    3. On the RSSD.
    rs_zeroltm DBSERVER,DBNAME
    This step will tell the RepServer to look at the secondary marker from the start of the transaction log.
    4. sp_start_rep_agent <dbname>

    If you have used sp_config_rep_agent 'disable'

    1. dump tran with truncate_only.
    2. sp_config_rep_agent 'enable'..... This will also set the valid trunc marker.
    3. On the RSSD.
    rs_zeroltm DBSERVER,DBNAME
    This step will tell the RepServer to look at the secondary marker from the start of the transaction log.
    4. sp_start_rep_agent <dbname>
    Quote Originally Posted by miguialberto
    Hello,

    I am working in a replication environment with two servers (ASE 15.0.2) and one replication server (15.0.1) using MSA.

    The two servers contains only one databse which is marked to be replicated and replication works fine.

    Now I am working in the case that the replicated server is completly down (for example due to a catastrophe). I want to stop completly the replication and to delete the secondary truncation point to avoid a filling up from the transaction log.

    I have tried with "dbcc settrunc (ltm, ignore)" and to dump transaction log. In this case, the replication is stopped. Nevertheless, all the transactions that I execute until I set "dbcc settrunc (ltm, valid)" are replicated later on, so that means (I think) that the secondary truncation point is not removed. Otherwise, all the transactions that I execute while the truncation point is set to ignore should be not replicated.

    I have also tried with command "sp_config_rep_agent disable" but also all the transaction that I have executed are later on replicated when the replication agent is enable again.

    My question is: somebody knows a way to avoid the secondary truncation point to work in the transaction log? I want that all the transaction commited by ASE are truncated and never replicated to avoid a filling up from truncation log.

    Thank you in advance!

  3. #3
    Join Date
    May 2009
    Location
    Darmstadt, Germany
    Posts
    13
    Thank you for you fast answer!

    I think the problem I did is to first stop the rep agent by means of "sp_stop_rep_agent" and then "dbcc settrunc (ltm, ignore)".

    I am going to test it in your way and I will explain my result!

    Thank you again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •