Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2009
    Posts
    1

    Arrow Unanswered: Ora-22924 Snapshot too old

    Hi all

    I am using Oracle 11g.
    I have one LOB data table with size 11 GB.
    When i use dbverify to check corresponding data file, it returns some corrupted blocks. but table is working fine.

    While i am trying to export this table/schema, working fine until it reaced 10.5 GB, after that i am getting following error

    ORA-01555: snapshot too old: rollback segment number with name "" too
    small
    ORA-22924: snapshot too old


    i have increased undo TS, increased retention time, but getting same error.

    next increased PCTVERSION of LOB column value to 40. still no change.



    any help regd this??

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Somebody is doing DML & COMMIT against this table while export is underway.

    Code:
    22924, 00000, "snapshot too old"
    //  *Cause:  The version of the LOB value needed for the consistent read was
    //           already overwritten by another writer.
    //  *Action: Use a larger version pool.
    Last edited by anacedent; 06-19-09 at 15:52.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •