Results 1 to 4 of 4
  1. #1
    Join Date
    May 2004
    Posts
    95

    Unanswered: dbms_scheduler doesn't run

    Hi all,

    I've got a package that I need to run periodically, but my dbms_scheduler doesn't run.
    Here's my code for you can see if there's anything wrong.
    Code:
    begin
        dbms_scheduler.create_program (
           'RUN_ROBOT'
          ,'STORED_PROCEDURE'
          ,'UPDATE_PKG.UPDATE_ROBOT'
          ,1
          ,FALSE
          ,'package robot.');
          
        dbms_scheduler.define_program_argument (
           'RUN_ROBOT'
          ,1
          ,'w_trash'
          ,'NUMBER'
          ,1
        );
        
        dbms_scheduler.enable(name => 'RUN_ROBOT');
    
        dbms_scheduler.create_schedule(  
          'SCHEDULE_ROBOT'
        , SYSTIMESTAMP
        , 'FREQ=HOURLY; BYMINUTE=0,2,4,6,8,10'
        , null
        , 'XPTO');
    END;
    Thanks.

  2. #2
    Join Date
    Jun 2004
    Location
    Liverpool, NY USA
    Posts
    2,509
    have you set job_queue_processes to a non zero value? Did you commit after submitting the job?
    Bill
    You do not need a parachute to skydive. You only need a parachute to skydive twice.

  3. #3
    Join Date
    May 2004
    Posts
    95
    yes.
    when I run a dbms_job.submit, all works fine.

    I've choose a scheduler, because the reccursive jobs are deleted if I restart the database, which I believe that doesn't happens in the scheduler.

    thanks.

  4. #4
    Join Date
    May 2004
    Posts
    95
    i've changed from program to job and now it's all working fine

    BTW, can anyone confirm me if after a database restart this schedules will still run?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •