Results 1 to 1 of 1
  1. #1
    Join Date
    Jun 2009

    Unanswered: Out of Memory! error

    Hi all,

    I am relatively new user to perl DBI DBD. I am presently getting an "Out of memory!" error when i run a perl script. Please find the details regarding the same

    I have two applications( consider application A and B)I am not a root user and hence I have installed perl DBI and DBD in my local home directory.The versions I have installed are Perl 5.8.4, DBI 1.608 and DBD 1.23. There is an earlier version of perl, DBI and DBD installed( perl 5.00503, DBI version 1.58 and DBD version of 1.20 ) at the location where my application A is installed. I have changed my application A's scripts to point to my local installation of perl, DBI and DBD and ran the scripts. What these scripts do is that it connects to Application A's database, queries for data and writes to application B's database.The scripts run successfully and updates the Application B's database( Oracle 10g) successfully but throws an "Out of memory!" error at the last. But these scripts donot throw any error when pointing to the default perl,DBI and DBD installations of application A. It looks like the error is being thrown when the script tries to connect to Application B's database( Tried using a exit; statement before and after DBI->connect and the error was appearing only when the statement gets executed).

    It looks like one of my colleague had got the same error sometime back for the same scripts and the issue was resolved when he reverted the perl verion back from 5.8 to 5.00503. So I doubt whether there must be some compatibility problem with my local perl installation and application B's perl installation. I have been stuck with this problem for sometime now.

    Please help me by providing inputs
    Last edited by sanjuthom; 07-01-09 at 05:23.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts